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download at http://systemc.org/ . This software is redistributed by Agilent. The Contributors of the
SystemC software provide this software "as is" and offer no warranty of any kind, express or implied,
including without limitation warranties or conditions or title and non-infringement, and implied
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 Data Display Basics 
Data generated by a simulation, as well as data that has been imported from other sources, such as a
network analyzer or CITIfile, is stored in a dataset. The Data Display window enables you to view and
analyze a dataset.

In a Data Display window you can:

Display data in a variety of plots and formats  
Create plots with more than two axes.
Add markers to traces to read specific data points
Write mathematical equations to perform complex operations on data, and display the results
Add text and drawing objects to enhance your documentation
Edit plot titles and axis labels, equations, text, drawing objects, and column headings in lists.

Data can be plotted on rectangular plots, polar plots, Smith charts, and stacked plots. Data can be
displayed as linear traces,  histograms, scatter plots, and spectral plots, as well as in digital and wide-
word (bus) data formats. In addition to graphical displays of data, data can be viewed numerically in
lists.

The basic process of creating a data display consists of the following steps.

The various plot and trace types enable you to display data in different formats. In addition, you can
use equations to perform complex mathematical operations on data for further analysis.
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 Opening and Closing Data Display Windows
You can open a new Data Display window by following any of the following methods:

From ADS main window, choose Window > New Data Display to open the new Data Display
window.

From the ADS main window, click the New Data Display Window icon  in toolbar.

From the Schematic window, click the New Data Display Window icon .

To open additional windows from a Data Display window:

Choose Window > New to open a new window showing the same contents as the current
window.
Choose File > New (or click the Open A New Data Display Window icon) to open a new
empty window.

 
To open an existing data display file:

Choose Window > Open Data Display from the ADS Main or Schematic window, select the data
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display file (.dds), and click Open.
From the Data Display window and choose File > Open. Select the data display file (.dds) and
click Open.

To close a data display window:

Choose Window > Close in the window you want to close. This closes only the active window
and does not affect the rest of the data display. If the contents of the display have been modified
and it is the only window displaying data from that data display file, you will be prompted to save.
Choose File > Close to close all windows that are showing the current data display file (if the
contents have been modified, you will be prompted to save). When the data display file is opened
again, the same number of windows will be opened to display it.

The basic elements of a data display window are:  

The Menu bar displays the menus that are available in a Data Display window.
The Dataset List displays the datasets available in a Data Display window.
The Title bar displays the window type, filename, and a number for identifying which data display
window it is.
The Toolbar contains buttons for frequently used commands.
The Display Area is where you create your data presentations.
The Data File Tool enables you to transfer data between datasets and files that are in the
following file formats:

Touchstone
Measurement data interchange format (MDIF)
CITIfile
IC-CAP

  

 Inserting Pages
The Data Display enables you to add multiple pages to the display area. Multiple pages provide you
with additional display area that can be used to display and organize large amounts of data. To insert a
new page:
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Choose Page > New Page. The New Page dialog box appears.1.
Enter a new name for the page.2.
Click the OK button to close the dialog box and insert the page.3.

 

 Viewing Multiple Pages

When you have more than one data display page, the quickest way to select a page for viewing is to
click on one of the tabs at the bottom of the Data Display window. (The tab name for the currently
selected page is highlighted with a white background.) You can also select a page by name from the
list at the bottom of the Page menu, or select Page > Next Page or Page > Previous Page.

You can also step through the sequence of pages using the View Previous Page and View Next Page
buttons on the toolbar as illustrated below:

Note
If there is only one page, the menu items and page buttons described above are not displayed; however, a tab for the
existing page is always visible.

 Changing the Page Order

The left-to-right order of the pages, as represented by the tabs, is the same as the top-to-bottom
order of the pages as listed in the Page menu. When a new page is added, a new tab appears (as the
rightmost tab), and a new name is added to the menu list (at the bottom). However, the order of the
pages can be changed if necessary.

To change the page order, simply click on a tab and drag it left or right to the desired position. The list
shown in the Page menu will be updated automatically to show the new sequence.

  

 Creating a Data Display
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The basic process of creating a data display consists of:

Choosing a dataset (by name) to display
Choosing a plot type for the display (Rectangular, Polar, etc.)
Specifying the data variable to be displayed
Choosing a trace type (Linear, Scatter,  Histogram, etc.)

Note
The application uses the Auto trace type by default. In some cases, Auto will not provide accurate results and a
trace type will need to be manually selected.

The various plot and trace types enable you to display data in different formats. Equations enable you
to perform complex mathematical operations on data for further analysis.

Optionally, you can enhance your data display by adding:

Markers identifying specific data points
Text for clarification
Graphical objects, such as lines and circles

   

 Using a Dataset 
The numerical data presented in a data display window comes from two sources, datasets and
equations. Datasets collect and store data either from internal sources, such as a simulation, or from
external sources, such as a network analyzer or Touchstone file.

Using the  data file tool, you can  read a data file (i.e., Touchstone, MDIF, Citifile, or ICCAP) into a
dataset, or you can  write a data file from a dataset. To use the data file tool, choose the Tools >
Data File Tool menu item. The dftool/mainWindow appears. Note that you may need to expand your
window to view all available options.

For detailed information on using the data file tool, refer to Reading and Writing Data Files (cktsim) in
Using Circuit Simulators (cktsim).

For information on how to write equations, refer to Equations (data).

  

 Choosing a Dataset

When you open a Data Display window, all datasets defined for the current workspace are available for
display. One dataset is selected as the default; it will be used as the source of data unless a different
dataset is chosen. If no datasets have been defined for the current workspace, the label on the drop-
down menu displays the current design name.

You can also view datasets that are stored under other workspaces or are not part of a workspace,
such as a dataset that contains measured instrument data. This can be useful for comparing simulated
versus actual results or comparing results between workspaces.

The data display does not store any data, it only retrieves and displays the data within a dataset.
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Thus, if the data in the dataset changes (for example, if you alter a design and re-simulate), the data
display will be updated to reflect the most current information in the dataset.

To choose a dataset:

Click the arrow to view the drop-down list of currently defined datasets.1.
Choose the name of the desired dataset. The Datasets and Equations list box is updated to reflect2.
the data variables contained in the selected dataset.

   

 Adding a Dataset

To view a dataset outside of the current workspace:

Choose Insert > Plot.1.
Position the pointer, click, and select a plot type.2.
Click the Manage button in the Plot Traces& Attributes dialog box. The Dataset Alias Manager3.
dialog box appears.
By default, datasets are saved with the .ds extension under the <workspace_name>/data4.
directory. Navigate to the file of interest and select the file. For more information, refer to Dataset
Aliasing.
Click OK.5.

 

 Using the Dataset Browser

The  Dataset Browser enables you to clearly identify the hierarchy associated with a dataset variable
name by displaying information in a tree structure. The browser also enables you to examine or select
dataset variables from more than one dataset at a time.

The Dataset Browser is activated by selecting Hierarchy option from drop down list. This option is
available from three different dialog boxes in the Data Display:

Plot Traces & Attributes
Enter Equation
Browse Data
The functionality of this feature is the same regardless of how it is accessed.

 

 Example

To browse through the datasets and equations hierarchy using the dataset browser:

Choose Insert > Plot.1.
Position the pointer and click. The Plot Traces & Attributes dialog box appears.2.
Select a dataset from the Datasets and Equations drop-down menu.3.
Select a dataset variable from the list box and select the Hierarchy option from the drop down4.
list. Note that the variable you selected in the flat view remains selected in the tree view. The
dataset variables that are available in a dataset are displayed in the Datasets and Equations list
box in a tree structure.

Note
In the tree view, when variables are selected and added to the trace list on the right, they are displayed in the
trace list with the short unique name (same as in the flat view).
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Use the + / - to further expand or collapse each item in the list. When a dataset is expanded, the5.
hierarchy of the dataset variables within the dataset is displayed.

Note
Only the lowest level nodes can be selected in the dataset. More than one dataset variable may be selected in a
dataset and the variables do not need to be included in the same dataset.

Select the List option to return to the default (flat) view. Only the shortest unique names are6.
displayed in the flat view.

Note
When Hierarchy display is switched back to the flat view, the last item selected or expanded in the tree view is
displayed in the flat view.

  

 Dataset Aliasing
The Dataset Alias Manager enables you to assign a shorter alias name to a dataset and use it within
the Data Display in place of the longer dataset path name. Aliases and their associated datasets can be
saved and made available between sessions.

 

 Using the Dataset Manager

Dataset alias names are managed using the Dataset Alias Manager in the Data Display. From within
the Dataset Alias Manager you can:
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Add a new alias
Edit an existing alias
Remove an existing alias

To access the Dataset Alias Manager from a Data Display window:
Choose File > Manage Dataset Aliases to start the Dataset Alias Manager dialog.

You can access the Dataset Alias Manager window from several other locations in the Data Display
window such as:

From the Plot Traces & Attributes dialog box, click the Manage button to start the Dataset Alias
Manager dialog.
From the Enter Equations dialog box, click the Manage Datasets button to start the Dataset
Alias Manager dialog.

To add a new alias to the Dataset Alias Manager window:

Click the Add Alias button. The Add Dataset form appears.1.

Click the Browse button and use the dataset browser to locate a dataset. Click the Add button in2.
the browser window to add the specified dataset to the Add Dataset form.
In the Add Dataset form, a unique alias name is supplied by default for newly selected datasets.3.
You can choose your own unique alias and override the default name by simply typing over it in
the Alias field.

Note
When choosing an alias name, try to select a unique name to avoid conflicts with existing aliases.

Click OK to add your new alias. Aliases are checked for unique names. If a conflict occurs, an4.
message is displayed asking you to resolve the conflict. Choose a different alias name or remove
the existing alias in conflict.
After you have added the new alias to the Dataset Manager window, click OK in the Dataset5.
Manager window to save your changes.

To edit an existing alias from the Dataset Alias Manager window:

Select an alias in the Dataset Manager window and click the Edit Alias button. The Edit Alias1.
form appears.
Modify the alias and/or dataset of the selected entry.2.
Click OK to implement your changes. The modified alias appears in the Dataset Manager.3.

To delete an existing alias from the Dataset Alias Manager window:
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Select an alias in the Dataset Manager and click the Remove Alias button. A confirmation1.
message appears asking if you are sure you want to remove the alias.
Click OK to confirm removing the alias or Cancel to abort the process.2.

  

 Saving a Data Display  
 
There are three commands available for saving a data display: Save, Save As, and Save Copy As.

Choose File > Save to save changes to the current data display window to an existing file. A file
suffix of .dds is automatically appended to a data display file. Note that .dds files should be saved
in the <workspace_name> directory.
Choose File > Save As to save the current data display window to a new file and change the
currently open window view to the new file.
Choose File > Save Copy As to save the current data display window to a new file and leave the
currently open window view of the original file.

  

 Exporting a Data Display Plot or List to an ASCII file
 
Data displayed in rectangular plots, polar plots, Smith charts, stacked plots, and lists can be saved to a
tab-delimited ASCII file.

To export a data display plot or list to a tab-delimited ASCII file:

Select one or more plots or lists.1.
Choose File > Export > Write selected item to tab-delimited ASCII. The Write Data To2.
ASCII File window appears.
Enter a filename then click OK. A file suffix of .txt is automatically appended to the selected file3.
name.

 Exporting a Data Display List to a CSV file
Data displayed in lists can be saved either as an ASCII file (as described above) or as a file in the CSV
(Comma Separated Values) format. The CSV format is commonly used by spreadsheet applications
and other tools (for more information on this format, see Exported List Data (CSV Format) (data)).

To export a data display list to a CSV file:

Select one or more lists.1.
Choose File > Export > Write selected list to CSV file, or else right-click on the selected lists2.
and select Export > CSV from the pop-up menu. The Open CSV Export File window appears.
Enter a filename then click OK. A file suffix of .csv is automatically appended to the selected file3.
name. An example of a CSV export is illustrated below; the list of S-parameters in the data
display is reproduced fully in the exported CSV file, viewed here in Microsoft Excel.
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 Using a Template in Your Display
Templates are files that contain only the items that are placed in a display area. Templates enable you
to store pre-configured plots and other graphical items, which you can use in any data display. For
example, you may have a standard set of plots that you use in different workspaces. Rather than
reinsert the plots and edit them for each data display, you design it once and save it as a template.
You can then add these plots to any data display window by inserting the template.

Templates can include not only plots but traces, markers, annotation, or any other item that can be
inserted in the display area. The only thing that is not saved in a data display template is the default
dataset.

To save a data display as a template:

Choose File > Save As Template in the Data Display window. The Component Library/Save1.
Template Browser appears.
In the Libraries list, select a directory in which to save the template.2.

Product - This selection contains templates that are shipped with the product. Templates in
this section are located in $HPEESOF_DIR/circuit/templates
User - This selection provides a location for personal templates. Templates in this section
are located in $HOME/hpeesof/circuit/templates.
Customized - This selection is where site specific templates should be placed. This category
may not appear in the browser if there are no templates stored in this location. Templates in
this section are located in $HPEESOF_DIR/custom/circuit/templates.

Note
The Product and Customized directories are typically specified as read only so you may not have
permissions to save to these directories.



Advanced Design System 2011.01 - Data Display

17

Supply a name and click OK. The extension .ddt is automatically appended to filenames of data3.
display templates.

To insert a data display template in an existing data display:

From the Data Display window, choose Insert > Template. 1.
Navigate to the name of the template file that you want to use.2.
Click OK.3.

To insert a data display template in a new data display:

From a Data Display window, choose File > New.1.
Choose Insert > Template.2.
Navigate to the name of the template file that you want to use.3.
Click OK.4.

Click here (data) to see the Product (built-in) templates that are available to facilitate setting up
common measurements.

  

 Viewing the Display Area
To aid in viewing your work, the following commands are available from the View menu and as buttons
on the toolbar.

Command Button Description

View > View All View All View all graphical objects on the display area

View > Redraw View Redraw View Redraw the current view in the display area

View > Zoom > Zoom Area Zoom Rectangle Zoom in so the selected area fills the window

View > Zoom > Zoom In x2 Zoom x2 Zoom in to make objects appear twice as large

View > Zoom > Zoom Out x2 Zoom x1/2 Zoom out to make objects appear twice as small

View > Zoom > Actual Size Actual Size View objects at actual size

Like other windows in the product, the Data Display window has scroll bars along the window edges so
you can pan across the display area.

      

 Scrolling Data in Lists and Plots

The Data Display toolbar includes (by default) a set of scroll buttons which enable you to scroll through
long lists of data in list columns, or to scroll through data points in a rectangular plot (single or
stacked). Because scrolling is slightly different in the case of a plot, separate procedures are given
below.

 To scroll through list data:

Click on the list to select it.1.
If the scroll buttons are not currently visible in the toolbar, right-click on the list and select Scroll2.
Data... from the popup menu; a small window containing the scroll buttons appears.
(Alternatively, select Scroll Data from the View menu, and then select the displayed options for
scrolling left and right.)
Use the scroll buttons as indicated in the figure below.3.
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 To scroll through plot data:

Note
The scroll buttons are only functional in cases where data zooming has restricted the amount of data shown in the plot. If
the data-zoom buttons in the toolbar ("Zoom In On Data By Specifying A Rectangle" and "Zoom In On Data") have been
used to restrict the displayed data to a given range, the scroll buttons can be used to step through the rest of the data. If
the "Autoscale Plot" button has been used to display all data, the scroll buttons will not be functional.

Click on the plot (not the trace) to select it.1.
If the scroll buttons are not currently visible in the toolbar, right-click on the plot and select2.
Scroll Data... from the popup menu; a small window containing the scroll buttons appears.
(Alternatively, select Scroll Data from the View menu, and then select the displayed options for
scrolling left and right.)
Use the scroll buttons as indicated in the figure below.3.
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 Editing a Data Display
You can make changes to the data display as you work. The typical sequence is to select the object
you wish to edit, then perform the operation. In some cases, you can select the command first and
then the object. If an edit command has this capability, it is noted.

    

 Selecting Objects  

You can select one, several, or all objects on a data display area to facilitate editing your work. A
selected item is enclosed with a dashed outline and handles. A selected trace has a thicker, dashed
appearance.

The following select options are available.

Option Action

Select one object Click the object.

Select several objects Shift+click the objects.

Select all objects Choose Edit > Select All.

  

 Deselecting an Object

If you want to deselect an object, click anywhere on the display area that is not occupied by the
object.

   

 Moving Objects 

You can move an object anywhere on the display area.
To move an object:

Select the object.1.
Drag the object to the new position.2.
The object remains selected and can be moved again.3.
To move several objects:
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Select the objects.1.
Hold down the Shift key and drag the objects to the new position.2.

Hint
You can use the automatic panning feature by dragging an object to the edge of the data display window. While
dragging an object, the window will automatically pan when the cursor is placed at the very edge (within a few
pixels) of the display area. Note that you must be within the window, not the window border or scroll area.

   

 Snapping Objects to the Grid

A grid can be set up for the data display so that plots, lists, and other screen objects snap to the grid
when they are moved or resized. This makes it easier to move the objects into exact alignment on the
display, or to space them evenly.

In the illustration below, the grid has been set up to be visible, and to appear in the form of black dots
(the grid can also be displayed as lines, or hidden entirely). The color and spacing of the displayed grid
are configurable.

The snap origin for any object is located at the object's upper left corner (as indicated by the small
green circles in the illustration below). When you move an object, it is the upper left corner which will
snap to the nearest grid point. However, when you stretch an object by selecting it and dragging any
of its corners, the edge that you are dragging will also snap to the grid.

 Scaling Objects 

To scale an object:

Select the item.1.
Drag one of the object handles to reduce or enlarge the object to the desired size.2.
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 Arranging Objects 

Arranging objects is useful when you have overlapping objects. Select the object of interest and
choose an arranging option.The following options are available.

Command Description

Edit > Arrange > Move to Front Displays the selected object in front of all other objects

Edit > Arrange > Send to Back Displays the selected object behind all other objects

Edit > Arrange > Move Forward Exchanges the positions of the selected object and the object in front of it

Edit > Arrange > Move Backward Exchanges the positions of the selected object and the object behind it

 

 Activating or Deactivating Objects

If you want to selectively deactivate a plot or an equation in a data display:

Select the object or objects.1.
Click the Toggle Activation of Object button on the toolbar or choose Edit > Toggle Activation.2.

Once an object is deactivated, a red 'X' is drawn through the object to indicate that it has been
deactivated. The object will not respond to any dataset updates while inactive. Equations are also
removed from the variables list when inactive. This feature can be helpful in troubleshooting or
when trying to speed up the re-draw process.

To activate a previously deactivated object:

Select the object or objects.1.
Click the Toggle Activation of Object button on the toolbar or choose Edit > Toggle Activation.2.

 

 Cutting, Copying, Pasting, and Deleting

You can perform cut, copy, paste, and delete operations in the Data Display much like other windows
in the product. First select an item in the display area, then choose a command.

Command Action Keyboard Shortcut

 Edit > Cut Erase the selected object from the display area and place it on the clipboard CTRL + X

 Edit > Copy Place a copy of the selected object on the clipboard CTRL + C

 Edit > Paste Place the object on the clipboard in the display area CTRL + V

 Edit > Delete Erase the selected object without placing it on the clipboard DEL
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 Setting Data Display Preferences
The appearance of each type of graphical object can be customized in a number of ways, depending on
the type of object. Objects are drawn initially using program defaults, but you can change these
characteristics and use them as new defaults for all workspaces, or you can save your settings to a file
for use in an individual workspace.

To set new defaults for all workspaces:

Choose Options > Preferences.1.
Modify any or all settings as desired and click Save.2.
Save the modified settings in $HOME/hpeesof/config/ddsdefaults.ael.3.
Click OK.4.

To save preferences for an individual workspace:

Choose Options > Preferences.1.
Modify any or all settings as desired and click Save.2.
Type the desired filename and click OK.3.
 

To read a preferences file:

Choose Options > Preferences.1.
Click Read. Navigate to the preferences file, then select the file. Objects will be drawn using the2.
new preferences.
Click OK.3.

You can save different sets of preferences to different files. You can update a Data Display window at
any time with a new preferences file. Reading in new preferences overwrites the existing ones.

For information on the characteristics you can change for the different types of objects, refer to the
appropriate section.

Preferences to be Edited Refer to

Plots and lists Plots and Lists (data)

Traces Traces (data)

Equations Equations (data)

Lines, polylines, rectangles, circles, polygons Setting Object Preferences (data)

Markers Markers (data)

Text Setting Text Preferences (data)

Grid/Snap Setting Grid/Snap Preferences (data)

  

 Printing
The Data Display's print functions enable you to print the current page, selected item, or all pages. The
print functions are available from the File menu. For information on setting up printers, refer to the
ADS "Schematic Capture and Layout" documentation.

  

 Locating Data Display Examples
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Many of the designs in the ADS Examples directory include data displays. The data displays use a
variety of plots, trace formats, markers, and many include equations. These examples can help you
design your own data displays so that you can analyze simulation data effectively. A list of some of the
examples is given below.

Examples
Subdirectory

workspace Data Displays

Com_Sys BER_wrk Displays bit-error rate data in lists, as time-domain waveforms, and on scatter plots.

 cdmafilter_wrk Displays the frequency response, unit step response, and unit pulse response of a
filter.

 DeltaSigma_wrk Displays the magnitude of the output of a delta-sigma modulator on a rectangular
plot.

 gsm_wrk Displays a variety of waveforms generated in a basic GSM 0.3 GSM system, including
the output data, recovered clock, recovered carrier, modulated spectrum, and MSK
trajectory.

 IS95_wrk Displays the spectrum of a simple IS95 forward channel carrier on a rectangular plot.

 rfsystem_wrk Displays a wide range of simulation results, including TOI in spectral format, budget
data in lists, and channel spectra.

 widebandcdma_wrk Displays waveforms generated in a wide CDMA modulator.

DSP CHBT_TH_wrk Displays a wide range of results simulating the output from a Sine wave.

Momentum Balun_wrk Compares S-parameters of a balun in magnitude and phase on rectangular plots.

 BoxExample_wrk Compares the S-parameters from the box example to a set of reference S-
parameters.

 Coupled_Stubs_wrk Displays S-parameters in magnitude and phase on rectangular plots.

 CPW_line_wrk Displays S-parameters in magnitude and phase on rectangular plots.

 Hairpin_filter_wrk Displays the response of the filter.

 Low_pass_filter_wrk Compares measured S(2,1) data to Momentum and Advanced Design simulations.

 Lp4_8Ghz_wrk Identifies the numerical noise floor of the filter.

MW_Ckts LNA_wrk Displays a wide range of results from the simulations of a low-noise amplifier,
including the S-parameters of an optimized amplifier displayed using lists, Smith
charts, and rectangular plots; sweeps of collector-emitter voltage and collector current
that display similar to a curve tracer; and the amplifier output from multiple input
tones, displayed in spectral format.

 mw_filter_wrk Displays the S-parameters of a 12 GHz bandpass filter, scaled for display on a
rectangular plot.

  

 Customizing Keyboard Shortcuts
You can redefine default keyboard shortcuts as well as create new ones. These shortcuts are
maintained individually for the different windows.

To change or add a keyboard shortcut:

Choose Options > Hot Key/Toolbar Configuration and click the Hot Key tab in the dialog box1.
that appears.
Select the menu name or menu/command sequence from the Category list box.2.
Select the command from the Item list box. If a shortcut currently exists for the item, the current3.
assignment is displayed.
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Select the modifier key(s)-Ctrl, Alt, Shift-and type the letter(s) you want to use in the Key field4.
(UNIX is case-sensitive; the PC is not). If the combination you choose is currently assigned to
another command sequence, you are warned and given the choice to proceed or to select another
key sequence.

Note
If you use Alt as the modifier key, and a letter that is already assigned as an accelerator for a menu (see the
underscored letters on the menu bar), the menu accelerator is replaced by your custom shortcut (with no warning).

To replace the assignment with your own choice, continue, otherwise choose a new key5.
combination and click Apply. When you are through making all keyboard changes, click OK to
dismiss the dialog box.

 

 Shortcut Keys

Shortcut Keys lists the default keyboard shortcuts found in the Data Display windows. Some of the
ADS individual tools also offer the ability to customize shortcut keys. For details on customizing these
shortcuts, refer to the section, Customizing Keyboard Shortcuts.
 

 Shortcut Keys
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File Commands

New Ctrl + n

Open Ctrl + o

Save Ctrl + s

Print Ctrl + p

Edit Commands

End Command Esc

Undo Ctrl + z

Redo Ctrl + y

Cut Ctrl + x

Copy Ctrl + c

Paste Ctrl + v

Delete Del

Select All Ctrl + a

View Commands

View All Ctrl + f

Window Commands

New Ctrl + Shift + D

Close Ctrl + F4

Help Commands

What's This? Shift + F1

Topics and Index F1

Sorted Default Shortcut Keys lists the default shortcut keys, in alphabetical order, to enable you to see
at a glance which ones are in use. If you attempt to assign any of these to other commands, you are
warned and given the choice to proceed or to select another key sequence (see footnote for Alt).
 

 Sorted Default Shortcut Keys

Ctrl Ctrl + Shift Shift Alt Others

Ctrl + a  Shift F1  Del

Ctrl + c    Esc

Ctrl + f    F1

Ctrl + f4     

Ctrl + n     

Ctrl + o     

Ctrl + p     

Ctrl + s     

Ctrl + v     

Ctrl + x     

Ctrl + y     

Ctrl + z     

If you use Alt as the modifier key (when creating custom shortcuts), and a letter that is already assigned as an
accelerator for a menu (listed in this table), the menu accelerator is replaced by your custom shortcut with no
warning.
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 Configuring Toolbars
By default, the toolbar in each data display window contains:

Buttons for Previous Page and Next Page.
A button for activating or deactivating plots and equations.
A drop-down list for selecting the default dataset.
Buttons used to scroll through lists and traces.
A button for autoscaling your plot.
Buttons used to zoom in and out of data.
A button used to start the Data File Tool.

You can reconfigure these default toolbars and create your own to better meet your design needs (
Options > Hot Key/Toolbar Configuration ).

 

 Customizing an Existing Toolbar

To reconfigure an existing toolbar:

Choose Options >  Hot Key/Toolbar Configuration and click the Toolbar tab in the1.
Configuration dialog box.
In the Toolbar Group list box, select the name of the toolbar you want to change.2.

To add or delete icons, use one of the following methods:3.
To delete an icon from the toolbar, select the associated command in the Tool Item list box,
and click the Cut button.

To add an icon to the toolbar, select the appropriate menu/command sequence from the
Menu Category list box, select the command from the Menu Item list box, and click the Add
button. The command is added to the Tool Item list box.
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Hint
When you add a button to the toolbar, its position relative to the other buttons is determined by its position
in the Tool Item list box. Before you click the Add button, be sure to highlight the command that the new
command should precede. In this example, Zoom Rectangle was highlighted before the Add button was
clicked so that View All would come before Zoom Rectangle.

If you want to edit another toolbar, click Apply to effect these changes and begin the process4.
again. When you are through making changes to the toolbars, click OK.

 

 Creating a New Toolbar

To create a custom toolbar:

Choose Options > Hot Key/Toolbar Configuration and click the Toolbar tab in the1.
Configuration dialog box that appears.

Hint
The position of the new toolbar, relative to the position of any existing toolbars, is determined by its position in the
Toolbar Group list box; the new name is added below the name that is highlighted when you click the Add button.
For example, if you keep both default toolbars and want to add a third one below them, highlight the bottom one
before you click the Add button.

Supply a name in the Toolbar Name field and click Add. The name entered is added to the2.
Toolbar Group list box.
Select the desired Menu Category, select the desired Menu Item and click the Add button above3.
the Menu Item. The command name is added to the Tool Item list box.
When you are through making changes to this toolbar, click Apply to effect the changes.4.
When you are through making changes to all toolbars, click OK.5.
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 Data Display Templates
Data Display Templates are files that contain only the items that are placed in a display area. These
templates enable you to store pre-configured plots and other graphical items that can be used in any
data display.

You can create your own templates or use default templates provided along with ADS release.

To create your own template you can save the file as template and then use the same in different
workspaces. Templates can include plots, traces, markers, annotation, or any other item that can be
inserted in the display area. The default dataset is not saved in a data display template.

To insert a data display template in an existing data display:

From the Data Display window, choose Insert > Template. 1.

In Data Display Insert Template window, select the name of the template file that you want to2.
use.

You can also search the template name in search window (on top of the window).

Click OK to insert the template.3.

To insert a data display template in a new data display, create a new file (File > New.) and follow the
above mentioned steps.

 List of Templates
The following table shows the Product (built-in) templates that are available to facilitate setting up
common measurements.
 

Data Display Template Description

BJT_curve_tracer BJT curve tracer with power consumption calculation.

FET_curve_tracer FET curve tracer with power consumption calculation.

S_ParamsQuad_Smith_Plr S11, S22 on Smith Charts; S12, S21 on polar plots.

S_Params_Quad_dB_Smith S11, S22 on Smith Charts; dB(S12), dB(S21) on rect. plots.

S_Params_Quad_dB_Smith_Log S11, S22 on Smith Charts; dB(S12), dB(S21) on rect. Log plots.

S_ParamsLargeSignal Displays the S-parameters as a function of frequency and input signal power,
as simulated by the S_ParamsLargeSignal schematic template. Is also
computes the Rollett stability factor, K, and group delay from these S-
parameters.

SProbeT Use with SProbeT schematic template
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SProbePairT Use with SProbePairT schematic template

S_21_11_wZoom dB(S21), S11 with "zoomed-in" frequency ranges.

Circles_Ga_NF Available gain and noise figure circles.

Circles_Ga_Stab Available gain and stability circles.

Circles_Stability Source and load stability circles and K.

HB1Tone Output power, gain, and harmonic distortion.

HB1ToneSwptFreq Output power, gain, harmonic distortion vs. frequency.

HB1ToneSwptPwr Output power, gain, harmonic distortion vs. power.

HB2Tone Output power, gain, TOI.

HB2ToneSwptPwr Output power, gain, TOI vs. power.

MixConvGainNF Mixer conversion gain, NF, noise contributors.

MixTOI Mixer output power, conversion gain, TOI.

Name_Date_Dataset Dataset name, date and time modified, data display name

SP_NWA_T Use with SP_NWA_T schematic template

SP_NWA_LogT Use with SP_NWA_LogT schematic template

SP_NWA_4PortT Use with SP_NWA_4PortT schematic template

SP_NWA_4PortLogT Use with SP_NWA_4PortLogT schematic template

SP_NWA_4PortBiasT Use with SP_NWA_4PortBiasT schematic template

SP_NWA_4PortBiasLogT Use with SP_NWA_4PortBiasLogT schematic template

SP_FET_T Use with SP_FET_T schematic template

SP_DiffT Use with SP_DiffT schematic template

SP_BJT_T Use with SP_BJT_T schematic template

LinearStepRespT Use with LinearStepRespT schematic template

LinearPulseRespT Use with LinearPulseRespT schematic template

DC_FET_T Use with DC_FET_T schematic template

DC_BJT_T Use with DC_BJT_T schematic template

ConvStepRespT Use with ConvStepRespT schematic template

ConvPulseRespT Use with ConvPulseRespT schematic template

GS_AC Use with Schematic Wizard template

GS_DC Use with Schematic Wizard template

GS_Device_FET_LP Use with Schematic Wizard template

GS_Mix_DI_CG Use with Schematic Wizard template

GS_Mix_DI_Spect Use with Schematic Wizard template

GS_Mix_SE_CG_FRFswp Use with Schematic Wizard template

GS_Mix_SE_CG_LOswp Use with Schematic Wizard template

GS_Mix_SE_Spect Use with Schematic Wizard template

GS_Oscillator_LoopGain Use with Schematic Wizard template

GS_Oscillator_Spect Use with Schematic Wizard template

YSH_template_1spec General Design Template for 1 Yield Specification

YSH_template_2specs General Design Template for 2 Yield Specifications

YSH_template_3specs General Design Template for 3 Yield Specifications

YSH_template_4specs General Design Template for 4 Yield Specifications

YSH_template_5specs General Design Template for 5 Yield Specifications

RF_PAE_DisplayTemplate WTB, RF PAE With Gating and Markers

RF_PAE_NoGating_DisplayTemplate WTB, RF PAE With No Gating

RF_PAE_NoMarkers_DisplayTemplate WTB, RF PAE With Gating, No Markers

RF_PAE_EVM_ACLR_DisplayTemplate WTB, RF PAE EVM ACLR

3GPPFDD_BS_RX_test WTB, 3GPPFDD Base Station RX test

3GPPFDD_BS_TX_ACLR WTB, 3GPPFDD Base Station TX ACLR
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3GPPFDD_BS_TX_CDP WTB, 3GPPFDD Base Station TX CDP

3GPPFDD_BS_TX_Envelope WTB, 3GPPFDD Base Station TX Envelope

3GPPFDD_BS_TX_EVM WTB, 3GPPFDD Base Station TX EVM

3GPPFDD_BS_TX_OccupiedBW WTB, 3GPPFDD Base Station TX OccupiedBW

3GPPFDD_BS_TX_PCDE WTB, 3GPPFDD Base Station TX PCDE

3GPPFDD_BS_TX_Power WTB, 3GPPFDD Base Station TX Power

3GPPFDD_UE_RX_test WTB, 3GPPFDD User Equipment RX Test

3GPPFDD_UE_TX_ACLR WTB, 3GPPFDD User Equipment TX ACLR

3GPPFDD_UE_TX_ACLR_ST WTB, 3GPPFDD User Equipment TX ACLR_ST

3GPPFDD_UE_TX_CDP WTB, 3GPPFDD User Equipment TX CDP

3GPPFDD_UE_TX_Envelope WTB, 3GPPFDD User Equipment TX Envelope

3GPPFDD_UE_TX_EVM WTB, 3GPPFDD User Equipment TX EVM

3GPPFDD_UE_TX_OccupiedBW WTB, 3GPPFDD User Equipment TX OccupiedBW

3GPPFDD_UE_TX_PCDE WTB, 3GPPFDD User Equipment TX PCDE

3GPPFDD_UE_TX_Power WTB, 3GPPFDD User Equipment TX Power

WLAN_802_11a_RX_ACR WTB, WLAN 802.11a RX ACR

WLAN_802_11a_RX_Sensitivity WTB, WLAN 802.11a RX Sensitivity

WLAN_802_11a_TX_Constellation WTB, WLAN 802.11a TX Constellation

WLAN_802_11a_TX_Envelope WTB, WLAN 802.11a TX Envelope

WLAN_802_11a_TX_EVM WTB, WLAN 802.11a TX EVM

WLAN_802_11a_TX_Power WTB, WLAN 802.11a TX Power

WLAN_802_11a_TX_Spectrum WTB, WLAN 802.11a TX Spectrum

WLAN_802_11b_RX_Sensitivity WTB, WLAN 802.11b RX Sensitivity

WLAN_802_11b_TX_Constellation WTB, WLAN 802.11b TX Constellation

WLAN_802_11b_TX_Envelope WTB, WLAN 802.11b TX Envelope

WLAN_802_11b_TX_EVM WTB, WLAN 802.11b TX EVM

WLAN_802_11b_TX_Power WTB, WLAN 802.11b TX Power

WLAN_802_11b_TX_Spectrum WTB, WLAN 802.11b TX Spectrum

TDSCDMA_UpLnk_RX_Sensitivity WTB, TD-SCDMA Uplink RX Sensitivity

TDSCDMA_UpLnk_TxConstellation WTB, TD-SCDMA Uplink TX Constellation

TDSCDMA_UpLnk_TxEnvelope WTB, TD-SCDMA Uplink TX Envelope

TDSCDMA_UpLnk_TxEVM WTB, TD-SCDMA Uplink TX EVM

TDSCDMA_UpLnk_TxPower WTB, TD-SCDMA Uplink TX Power

TDSCDMA_UpLnk_TxSpectrum WTB, TD-SCDMA Uplink TX Spectrum

TDSCDMA_DnLnk_MultiCarrier_TX_Power WTB, TD-SCDMA Downlink Multi-Carrier TX Power

TDSCDMA_DnLnk_MultiCarrier_TX_Spectrum WTB, TD-SCDMA Downlink Multi-Carrier TX Spectrum

TDSCDMA_DnLnk_RX_ACS WTB, TD-SCDMA Downlink RX ACS

TDSCDMA_DnLnk_TxConstellation WTB, TD-SCDMA Downlink TX Constellation

TDSCDMA_DnLnk_TxEnvelope WTB, TD-SCDMA Downlink TX Envelope

TDSCDMA_DnLnk_TxEVM WTB, TD-SCDMA Downlink TX EVM

TDSCDMA_DnLnk_TxPower WTB, TD-SCDMA Downlink TX Power

TDSCDMA_DnLnk_TxSpectrum WTB, TD-SCDMA Downlink TX Spectrum

HSUPA_UE_TX_MaxPower WTB, HSUPA User Equipment TX Maximum Power

HSUPA_UE_TX_Summary WTB, HSUPA User Equipment TX Tests Summary

UWB_TX_Spectrum WTB, UWB TX Spectrum

UWB_TX_Power WTB, UWB TX Power

UWB_TX_EVM WTB, UWB TX EVM

UWB_TX_Envelope WTB, UWB TX Envelope

UWB_TX_Constellation WTB, UWB TX Constellation
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UWB_RX_Sensitivity_test WTB, UWB RX Sensitivity

WMAN_DL_802_16e_TX_Constellation WTB, Mobile WiMAX Downlink TX Constellation

WMAN_DL_802_16e_TX_Envelope WTB, Mobile WiMAX Downlink TX Envelope

WMAN_DL_802_16e_TX_EVM WTB, Mobile WiMAX Downlink TX EVM

WMAN_DL_802_16e_TX_Power WTB, Mobile WiMAX Downlink TX Power

WMAN_DL_802_16e_TX_Spectrum WTB, Mobile WiMAX Downlink TX Spectrum

WMAN_DL_802_16e_RX_Sensitivity_test WTB, Mobile WiMAX Downlink RX Sensitivity

WMAN_UL_802_16e_RX_Sensitivity_test WTB, Mobile WiMAX Uplink RX Sensitivity

WMAN_UL_802_16e_TX_Constellation WTB, Mobile WiMAX Uplink TX Constellation

WMAN_UL_802_16e_TX_Envelope WTB, Mobile WiMAX Uplink TX Envelope

WMAN_UL_802_16e_TX_EVM WTB, Mobile WiMAX Uplink TX EVM

WMAN_UL_802_16e_TX_Power WTB, Mobile WiMAX Uplink TX Power

WMAN_UL_802_16e_TX_Spectrum WTB, Mobile WiMAX Uplink TX Spectrum
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 Plots and Lists
A variety of plot types can be inserted into a data display so that you can view data in different ways.
The different plot types are listed in the table below.

Plot Type Description

 Rectangular Displays scalar data in a linear or logarithmic format.

 Polar Displays real and imaginary components of complex data on a polar plot.

 Smith Chart Displays real and imaginary components of complex data on a Smith chart.

 Stacked Displays a vertical stack of rectangular plots, each with the same x axis and different y axes.

 List Displays data in columnar format.

 Antenna Displays 2D Far Field simulation results.

You can have more than one plot in a single window. Some plot examples:

  

 Inserting Plots
Follow the steps below to insert a plot:

From the DDS window, choose Insert > Plot or select a plot type from the palette.1.
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Position the pointer on the display area. A rectangle image is attached to the pointer which2.
indicates the position and size of the plot.

If you are satisfied with the size and position of the rectangle, press the mouse.
To change the size of the plot, position the pointer where you want the upper-left corner of
the plot, then drag the mouse. When the rectangle is the desired size, release the mouse.

The Plot Traces & Attributes dialog box appears. Plot types are shown across the top and the3.
selected plot type is highlighted. To change to a different plot type, click the desired plot type
button.

The lower part of the dialog box contains selections for adding traces to the plot. These are4.
described in Traces (data).
Click the Plot Options tab to set up the plot. Options include adding titles and scaling data.5.
Changing options are discussed in the next section.
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Click OK to insert the plot.6.

  

 Editing Plots 
The title, grid, scale and other attributes can be can changed for an existing plot. Any changes that
you make will only affect the currently selected plot. To change properties for all plots added
subsequently, see Setting Plot Preferences.

Note
Plot options for the chosen plot type are displayed automatically. If the plot options do not seem correct, click the Plot
Type tab, click the Plot button corresponding to the type of plot you want, then reselect the Plot Options tab.

To change the plot type:

Double-click the plot.1.
In Plot Traces & Attributes dialog box, select a new plot type from the Plot Type tab.2.

To edit various plot characteristics:

Double-click the plot of interest, or choose Edit > Item Options , and click the Plot Options tab.1.
When you are through editing plot characteristics, click OK to save the changes.2.

Most plots use two  axes but you can add an additional axis to rectangular plots. To add an additional
axis to your rectangular plot:

From the Plot Options tab, select an axis from the Select Axis list box and click Add Axis.1.
In the dialog box that appears, enter a name for the new axis, select the desired orientation and2.
click OK.
 

To add a title above a plot or edit an existing title: 

From the Plot Options tab, enter the desired title in the Title field.1.
To change the font, size or color of the title, click More and change the characteristics as desired2.
in the dialog box that appears, and click OK.

The names of the variables that are displayed on a plot appear along the axes of a plot. The names of
the independent and dependent variables are displayed on the x and y axes, respectively. You can
format the text along both axes and the numbers on a single axis.

Plots can display the data from multiple independent variables. Each time a trace is added to a plot, a
different color is used to draw the trace. The color of the label for that trace matches the color of the
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trace to help you identify the source of the data.

The figure shown next displays default axis labels. Note that if you give descriptive names to
schematic items such as named connections and variables, as well as to data display equations, you
may not need to change the default axis labels.

 
To format a plot's axis labels and numbers: 

Select the desired axis from the Select Axis list box and type the desired label in the Axis Label1.
field.

Note
By default, the names of the independent and dependent variables are displayed as labels along the axes of a plot.
If you enter text in the Axis Label field, the variable names along the selected axis will be replaced by this text.

Click More (to the right of the Axis Label field) to format the label characteristics. The Axis Label2.
dialog box appears.
In the Axis Label dialog box, select a Format for the numbers along the axis:3.

Auto A default format is automatically chosen, based on the type of data to be displayed
along the axis.
Full All digits before the decimal are displayed (i.e., 1530000).
Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as
1.00e3).
Engineering Numbers are displayed using engineering notation. For example, frequency
values end in Hz. Additionally, numbers are displayed in powers of 103 (for example, 1000
Hz is displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
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In the field to the right of the Format drop-down list, enter the desired # of Decimal Digits (for4.
Full) or Significant Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the
selected Format, the number of digits after the decimal is chosen automatically; any value in the
# of Decimal Digits field is ignored.
Select the desired font from the Font Type list.5.
Select the desired font size from the Font Size list.6.
Click the Color bar to select a new text color and click OK.7.

Note
If you set this to a color other than black, all labels will be displayed in this color.

Click OK to dismiss the Axis Label dialog box.8.

The scale on rectangular and stacked plots and Smith charts can be set to linear or logarithmic format.
The scale can also be different along each axis.

 To change the scale format, do the following:

Select the desired axis from the Select Axis list box.1.
Select the Auto Scale option.2.
Select either Linear or Log as the Scale type.3.
Select the other axis, as appropriate, and change its scale in a similar manner.4.

The data display automatically scales plot axes to display the entire range of a variable on the plot and
give an optimum view of the data.

For rectangular and stacked plots, you can manually set the start and endpoints of a plot to show
a limited range of data.
On polar plots and Smith charts, you can specify the radius of the plot and the range of data for
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the independent variable.

Note
You can scroll through traces that have more data than what is displayed on the plot. Select the trace, then use the
scroll buttons on the toolbar to scroll through the trace. For more information on scrolling, refer to Scrolling through
Lists and Traces (data). 

To manually scale a plot, do the following: 

Select the axis that you want to scale from the Select Axis list box.1.
Deselect the Auto Scale option.2.
Enter the starting value for the selected axis in the Min field.3.
Enter the ending value for the selected axis in the Max field. For Smith plots, this is the maximum4.
radius of the plot.
Enter the incremental value in the Step field (rectangular, stacked, and polar plots only). Grid5.
lines are drawn on this axis at these intervals.
For polar and Smith charts only, to limit the range of data displayed, deselect Display All and6.
enter the minimum and maximum values in the Start and Stop fields, respectively.

Note
For Smith charts only, the coordinates can be changed by selecting Impedance, Admittance, or Both from the
Coordinate drop-downlist. 

The type, thickness, and color of lines in a grid can be changed. On rectangular plots and stacked
plots, horizontal lines and vertical lines can have different properties. The same is true for impedance
and admittance lines on Smith charts.
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To edit a plot's grid :

For rectangular and stacked plots, select an axis from the Select Axis list box. Select the X axis to1.
format the vertical lines of the grid; select the Y axis to format horizontal lines. For stacked plots,
the Y axis on each plot must be formatted individually.
Click Grid. If the plot is a rectangular, polar, or stacked rectangular plot, you can modify the grid2.
attributes. For Smith charts, you can edit either the impedance or admittance lines.
Select a line type (solid, dot, dash, etc.) from the Type drop-down list.3.
Select a line thickness either by using the slider or by entering a value in the Points field.4.
Thickness can range from 0 to 10 points. The larger the value, the thicker the line will be drawn.
Click the Color bar, select a new color, then click OK.5.
Click OK to dismiss the Grid dialog box.6.

You can remove the grid from a plot. To remove the grid:

Click Grid. The Grid dialog box is displayed.1.
Deselect the Display Grid option.2.
Click OK to dismiss the Grid dialog box.3.

  

 Editing

Plot Axis Scales
The scale of a plot axis can be changed directly from a rectangular, polar, or stacked rectangular plot
by using the following steps:

Click on the first or last number label on the axis and enter a new value (on polar plots, you can1.
only change the outer-most number label).

Note
The value you enter in the number label depends on the unit of measure used for the axis. For example, if the x-
axis uses "freq (GHz)" as the unit of measure, typing 9 in the number label would result in the label having a value
of "9 GHz" rather than "9".

Press Return or click anywhere in the Data Display window to make the scale change take effect.2.

  

 Deleting Plots
To remove a plot, do the following:

To delete a single plot, single-click on the plot. For multiple plots, hold the Shift key down and1.
single-click on each plot of interest.
Press the Delete key or choose Edit > Delete.2.

Note
If you just want to disable a plot temporarily, refer to Activating or Deactivating Objects (data).

  

 Setting Plot Preferences  
Plot preferences set the default plot properties and determine the appearance of a plot in the display
area. Preferences affect all plot types and include setting the font type, size, and color for titles and
axis labels; the numeric format of axis labels; and the line type, width, and color of grids.
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Plot preference changes will apply to all plots created after the changes were made and saved. To
change the properties for an existing plot, refer to Editing Plots.

Data display preference settings can be saved for reuse by creating a preferences file. For more
information on how to create and use such a file, refer to Setting Data Display Preferences (data).

To set plot preferences, use the following steps:

Choose Options > Preferences.1.
The Preference dialog box appears. Click the Plot tab followed by the Main tab.2.
To set the plot title attributes, do the following:3.

Select a font from the Font Type list.
Select a font size from the Font Size list.
Click the Text Color bar, select a color, then click OK.

The axis numbers can be formatted for plots that use more than one axis. This is done as follows:4.
Select an axis label format from the Label Format list. The choices are:
Auto A default format is automatically chosen, based on the type of data to be displayed
along the axis.
Full All digits before the decimal are displayed (i.e., 1530000).
Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as
1.00e3).
Engineering Numbers are displayed using engineering notation. For example, frequency
values end in Hz. Additionally, numbers are displayed in powers of 103 (for example, 1000
Hz is displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or
Significant Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected
Format, the number of digits after the decimal is chosen automatically; any value in the # of
Decimal Digits field is ignored.

To format axis label text, click the Label button and make the following selections from the Axis5.
Labels dialog box:

Select a font from the Font Type list.
Select a font size from the Font Size list.
Click the Text Color bar, select a new color, then click OK.

Note
If you set this to a color other than black, all labels will be displayed in this color.

Click OK to dismiss the Axis Label dialog box.
To set grid preferences, click Grid and make the following selections in the Grid dialog box:6.

Select a line pattern from the Type list.
Select a line thickness either by using the scroll bar or by entering a value into the Points
field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin line is
drawn.
Click the Color bar, select a new color, then click OK.
Select a Smith chart admittance line pattern from the Type list.
Select a Smith chart admittance line thickness by using the scroll bar or entering a value into
the Points field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin
line is drawn.
Select a Smith chart admittance line color by clicking the Color bar, selecting a new color,
then clicking OK.
Click OK to dismiss the Grid dialog box.

To set the axis scale for linear and stacked plots, click the Linear, Stack tab and select Linear or7.
Log.
To set the coordinates used on Smith charts, click the Smith tab and select Impedance,8.
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Admittance, or Both from the Coordinate list.
Click OK to dismiss the Preference dialog box and save the changes.9.

  

 Antenna Plot
Antenna Plot provides a platform to display the Far Field data generated from Momentum that allows
you to plot generic magnitude and phase data. It also supports the display of arbitrary magnitude and
angle (degree) data.

Key features of Antenna Plot include:

Displays radiation patterns generated from ADS simulators.
DDS automatically checks for the independent data and display the data in the correct Antenna
Plot.
Theta and Phi data can be placed on the same plot. However, the first trace will determine the 0
degree orientation of the plot.
Option to change the Min and Max values of magnitude to be displayed on the plot.
Control over the step size used to create the concentric circles from the center of the plot.
Control over the degrees of separation between radial grid lines specified in degrees.
Values outside the plot's last radius are the degree values.
Min/Max values of the magnitude values can be edited on screen.
Magnitude values are displayed from center of the plot vertically regardless of 0 degree
orientation.

 Figure: Antenna Plot showing the planar cut with Theta as the independent data.

 Figure: Antenna Plot showing the conical cut with Phi as the independent data.
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 Plot Options

The "Plot Options" tab provides the following options to customize various display options of the
Antenna plot:

Title: To change the plot title.1.
Dependent Axis (Magnitude): To change the display options of dependent axis.2.
Independent Axis (Degree): To change the display options of independent axis.3.
Auto Scale: To change the scaling options.4.
Independent Variable: To change the independent variables, Theta or Phi, Start and Stop options.5.

 Figure: Plot Traces and Attributes - Antenna Tab
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 Title

Here you can provide the title to Antenna Plot. Click the More button to change the font style of plot
title.

 Dependent Axis (Magnitude)

To change the display options of dependent axis, click the More or Grid button.

 Figure: Dependent Axis More Button Dialog
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 Figure: Dependent Axis Grid Dialog

 Independent Axis

To change the display options of independent axis, click the More or Grid button.

 Figure: Independent Axis More Dialog

The Zero Degree Orientation drop down list contains the following:

Automatic
Vertical (Planar Cut)
Horizontal (Conical Cut)

When in Automatic mode, the orientation is controlled by the independent data.

 Grid Dialog

The Grid dialog allows you to control how often to display a radial grid line. The default value is 45
degree. Other supported values are: 10, 15, 30, 45 and 90 degres.

 Figure: Independent Axis Grid Dialog
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 Antenna Complex Data Dialog

The data inserted in Antenna Plot is usually complex. Since Antenna plot supports only scalar data you
will be prompted to choose an equation to the convert the data into scalar data. The following dialog is
displayed when you select the equation to apply:

 Figure: Data Conversion Dialog

 Inserting Lists  
To insert a list, do the following:

Select List from the palette or choose Insert > Plot.1.
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Position the pointer on the display area. A ghost image of a rectangle is attached to the pointer. It2.
indicates the position and size of the list.
If you are satisfied with the size and position of the rectangle, click the mouse.
If you want to customize the size of the list, position the pointer where you want the upper-left
corner of the list, then drag the mouse. When the rectangle is the desired size, release the
mouse.
The Plot Traces & Attributes dialog box appears. Plot types and list icon are shown across the top.3.
If the List icon is not highlighted, select it.

Click the Plot Options tab to set up the list. Options are provided for formatting the data.4.
Changing list options are discussed in the next section.
Click OK to dismiss the dialog box and insert the list.5.
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 Editing Lists
Except for titles, lists have options that are not common to the other plot types. You can change these
list settings:

Numeric format of data displayed in lists
Text format of data, such as font type and color
Format of the lines that outline a list
Display of column headings
Display of data in table format

Any changes that you make will only affect the currently selected list. To change the properties for all
subsequently created lists, refer to Setting List Preferences.

To edit a list, do the following:

Double-click on the list.1.
The Plot Traces & Attributes dialog box appears. Click the Plot Options tab.2.
To specify the numeric format of the data, do the following:3.

Select a format for the data from the Format drop-down list. The choices are:
Auto A default format is automatically chosen based on the type of data displayed. 
Full All digits before the decimal are displayed (for example, 1530000). 
Scientific Numbers are displayed in scientific format. For example, 1000 is displayed as
1.00e3. 
Engineering Numbers are displayed using engineering notation. For example, frequency
values end in Hz. Also, numbers are displayed in powers of 103 (1000 Hz is displayed as 1.0
kHz). 
Hex Numbers are displayed in hexadecimal (base 16). 
Octal Numbers are displayed in octal (base 8). 
Binary Numbers are displayed in binary (base 2). 
 To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or
Significant Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected
Format, the number of digits after the decimal is chosen automatically; any value in the # of
Decimal Digits field is ignored.

Note
If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the
columns, select the list and drag the lower-right or lower-left handle horizontally. 

To change the type font, size, and color of list text, do the following:4.
Click Listing Text.
Make the following selections from the Column Listing dialog box:
Select a font from the Font Type list
Select a font size from the Font Size list.
Click Text Color, select a color, then click OK.
Click OK to dismiss the Column Listing dialog box

The type, color, and thickness of the line around the perimeter of a list can be changed by5.
following  
these steps: 

Click Outline.
Make these selections from the Outline dialog box:
Select a line pattern from the Type list.
Select a line thickness either by using the Thickness scroll bar or by entering a value into the
Points field.
Click Color, select a new outline color, then click OK.
Click OK to dismiss the Outline dialog box.

Column headings  display the name of the variable that is the source of the data. They are6.
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displayed by default. To remove them, deselect Display Column Headings.
Table format is only used to display data with two independent and one dependent variable. It is7.
chosen automatically. To disable table format, select Suppress Table Format.
If you use table format, you can also transpose the data, which reverses the position of the two8.
independent variables. This is recommended if the independent variable data listed across the
table has more values than the independent variable data listed down the table. Transposing
would give you a longer, narrower table.
To transpose tabular data, select Transpose Data.
In the example below, the two independent variables are VCE and IBB. The measured data is IC.i.
The first list is in table format, which is the default and generally the best way to display data.
The second list uses table format and transposed data, note the change of position between VCE
and IBB. The third list is in suppressed table format, both independents are displayed in one
column.

Click OK to dismiss the dialog box and save the changes.9.

  

 Deleting Lists
To remove a list, do the following:

To delete a single list, single-click the list. For multiple lists, hold the Shift key down and single-1.
click on each list of interest.
Press the Delete key or choose Edit > Delete.2.

Note
If you just want to disable a list temporarily, refer to Activating or Deactivating Objects (data).
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 Setting List Preferences 
List preferences set the default list properties and determine the appearance of a list in the display
area. List preference changes will affect all lists created after the changes were made and saved. To
edit the properties of an existing plot, refer to Editing Lists.

To set list preferences, follow these steps:

Choose Options > Preferences.1.
The Preference dialog box appears. First select the Plot tab followed by the List tab.2.
To specify the numeric format of the data, do the following:3.

Select a format for the data from the Format drop-down list. The choices are:
Auto A default format is automatically chosen based on the type of data displayed.
Full All digits before the decimal are displayed (i.e., 1530000).
Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as
1.00e3).
Engineering Numbers are displayed using engineering notation. For example, frequency
values end in Hz. Also, numbers are displayed in powers of 103 (for example, 1000 Hz is
displayed as 1.0 kHz).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
To the right of the Format drop-down list, enter the desired # of Decimal Digits (for Full) or
Significant Digits (for Scientific, Engineering, Hex, Octal, Binary). When Auto is the selected
Format, the number of digits after the decimal is chosen automatically; any value in the # of
Decimal Digits field is ignored.

Note
If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the
columns, select the list and drag the lower-right or lower-left handle horizontally.  

To change the type font, size, and color of list text, do the following: 4.
Click Listing Text.
Make the following selections from the Column Listing dialog box:
Select a font from the Font Type list
Select a font size from the Font Size list.
Click Text Color, select a color, then click OK.
Click OK to dismiss the Column Listing dialog box

The type, color, and thickness of the line around the perimeter of a list can be changed by5.
following these steps:

Click Outline.
Make these selections from the Outline dialog box:
Select a line pattern from the Type list.
Select a line thickness either by using the Thickness scroll bar or by entering a value into the
Points field.
Click Color, select a new outline color, then click OK.
Click OK to dismiss the Outline dialog box.

Column headings display the name of the variable that is the source of the data. They are6.
displayed by default. To remove them, deselect Display Column Headings.
Table format is only used to display data with two independent and one dependent variable. It is7.
chosen automatically. To disable table format, select Suppress Table Format.
If you use table format, you can also transpose the data, which reverses the position of the two8.
independent variables. To transpose tabular data, select Transpose Data.
Select a complex data format from the Complex Data List. The choices are:9.
Real/Imaginary Real and imaginary values.
Mag/Degrees Magnitude and angle in degrees.
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dB/Degrees The dB value and angle in degrees.
Mag/Radians The magnitude and angle in radians.
dB/Radians The dB value in radians.
Click OK to dismiss the Preference dialog box and save the settings.10.

 

 Using Legends
 Legends are provided in Data Display to help you quickly identify specific traces in a plot. Often times,
sub-trace labels will appear placed on top of each other making it difficult, if not impossible, to identify
values assigned to a particular sub-trace. Legends can also help to identify a traces associated with
specific expressions.

Legends are especially helpful in ADS tuning sessions where it is important to keep track of the various
traces associated with specific tuning parameters. For more information on ADS tuning, refer to
Tuning, Optimization, and Statistical Design (optstat).

 

 Inserting a Legend

There are two methods available for inserting a legend. The first method is the pre-select method and
enables you to add legends to more than one plot at a time. The second method, or post-select
method only allows you to add one legend to a single plot.

To insert a legend using the pre-select method,

Click the plot that you want to attach a legend to.1.
Choose Insert > Plot Legend. The legend object always appears to the right of the plot. You can2.
then move the legend to any desired location.
Examples of Different Trace Formats shows an example of a plot that uses different trace formats
displayed in a legend.

 

 Examples of Different Trace Formats

To insert a legend using the post-select method,

Choose Insert > Plot Legend.1.
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Click the plot that you want to attach a legend to. The legend object always appears to the right2.
of the plot. You can then move the legend to any desired location.

 

 Deleting a Legend

Removing an existing legend is easy.

Simply click the legend that you want to remove to activate the legend.1.
Press the Delete key. The legend is removed.2.

 

 Changing Legend Fonts and Font Size

To change the  font and/or font size used in your legend,

Right-click the legend you want to change.1.
Select Text from the pop-up menu.2.
Select a new Font or Font size from the available options.3.
You can perform the same actions by choosing the Edit > Text pull-down menu item.

 

 Changing Legend Formats

There are two types of legend formats available for changing the legend display  format, the Indented
legend format and the Normal legend format.

Indented legend format is used to reduce the width of the legend by collapsing common columns
into a single width header. Indented legend format is the default for legends that have duplicate
adjacent data in a column and can help when you have long header or equation names.
Normal legend format is used when columns in the legend do not have duplicate adjacent data.
See the figure Examples of Indented and Normal Legend Formats for examples of both types of
legend formats.

To select the Normal legend format,

Click the legend you want to change.1.
Choose Edit > Legend > Format > Normal. The legend format is changed to Normal.2.
To return to the Indented legend format, simply choose Edit > Legend > Format > Indented.3.
The plot pop-up menu item also includes legend format capability under the Insert Legend menu
item. You can also access this capability from the Legend pop-up menu.
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 Examples of Indented and Normal Legend Formats
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 Traces
 
Traces are used to display the data that is stored in a dataset and the results of equations. There are
several trace formats available for displaying data. Selecting various combinations of traces and plot
types enable you to analyze simulation results in a variety of ways. Typical   trace types are listed in
the table below.

Trace
Type

Description

 Auto A default trace type that is assigned to the data during simulation is automatically selected.

 Bus Displays bus or long-word data in octal, decimal, or hexadecimal format.

 Linear Displays data as a line. Points between measured data points are interpolated linearly to create a connected
trace.

 Scatter Displays data as discrete points.

 Spectral Each data point is represented as an arrow that is perpendicular to the x-axis, the base of each arrow is on the
x-axis, and each arrow points in the positive direction.

 Histogram Displays data as a histogram or bar chart, which is useful for statistical or yield analyses.

 Digital Displays data in a stair format, similar to a digital pulse. The trace steps up or down depending upon the relative
position of two adjacent points.

 Sampled Similar to a spectral trace, except that vectors point in the positive and negative direction, and you can specify
the type of symbol used on the ends of the vectors.

 Density Displays swept data in different colors. You can choose the colors and sequence for colors.

Because an automatic trace type is selected for data, you can view simulation results with little effort.
If you want to analyze data in different ways, you can choose other formats or use equations to
perform computations with data. For more information, refer to Equations (data).

Examples of traces are displayed below.

  

 Inserting a Trace
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You can add a trace as you create a new plot, or you can add a trace to an existing plot.
To insert a trace onto a plot:

Double-click on an existing plot or create a new plot by selecting a plot type from the palette,1.
positioning the pointer over the display area, and clicking the mouse.
The Plot Traces & Attributes dialog box appears. Select the dataset containing the data from the2.
Datasets and Equations drop down list. There are two other choices: 

Select Equations from the Datasets and Equations list to display the results of an
equation on a plot. For more information, see Equations (data).  
Click Manage to set up an alias to display data in datasets that are not in the current
workspace. For more information, see Dataset Aliasing (data).  

The variables in the dataset are listed under the dataset name. To add a variable to the plot,3.
double-click on the variable or select the variable and click >>Add >> button. The selected
variables appear under the Traces list.  
A trace type for each selected variable is automatically chosen based on the type of data in the4.
variable. You can select a different trace type or change trace attributes such as color.
Click OK to insert the trace and return back to previous window.5.

  

 Selecting Independent and Dependent Variables 

When >>Add >> button is used to add data to a plot, the data is plotted with respect to the
independent variable of a simulation. For example, transient simulations are a function of time, so any
data from a transient simulation that is added to a plot using >>Add >> would be plotted with
respect to time.

If you want to use an independent variable other than the default, use >>Add Vs..>>. to add data to
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a plot. Note that the dependent variable must be the same length or size as the independent variable
when using >>Add Vs..>> to add data to a plot. Not doing so will result in an invalid trace. You can
use >>Add Vs..>> with rectangular plots and with lists. For rectangular plots, you select the
variables to be plotted along the x-axis and y-axis. For lists, the independent and dependent variables
appear in two separate columns.

Follow the steps below to compare two variables:

To compare two variables on a new plot, choose Insert > Plot, position the pointer, and click or1.
select a plot type from the palette. To compare two variables on an existing plot, double-click on
the plot. The Plot Traces & Attributes dialog box appears.
If this is a new plot, select a plot type.2.
For new and existing plots, select the dependent variable from the list below Datasets and3.
Equations and click >>Add Vs..>>.
If you are using a rectangular plot and the dependent variable you selected is a complex number,4.
the Complex Data dialog box will appear. Select how the data is to be handled and click OK.
The Select Independent Variable dialog box appears. Select the independent variable from the5.
list. It can be from a different dataset or equation. Click OK.
If the independent variable you selected is a complex number, the Complex Data dialog box will6.
appear. Select how the data is to be handled and click OK.
Click OK to dismiss the Plot Traces & Attributes dialog box and display the trace on the plot.7.

 Dataset Filtering

Dataset filter provide an option to interactively search the variables in the dataset by filtering the
characters entered in the search box. The variables are interactively filtered as the user types into the
search box allowing the user to see the results as they type. The Dataset filter is available in both the
List and Hierarchy variable display modes.

  

 Viewing Complex Data on a Rectangular Plot

The data from frequency-domain simulations, such as S-parameter or harmonic balance simulations, is
stored in complex format. You can plot data from these simulations on rectangular plots, but you must
scale the data to one of the following formats: 

dB
dBm
Magnitude
Phase
Real
Imaginary

When you select the data and click Add or Add Vs, if the data must be scaled the dialog box shown
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below will automatically appear. Select a format and click OK, and continue with the plot as usual.

When adding one trace at a time, additional checking is performed based on the simulation type of the
selected trace. For example, if a trace is associated with a swept harmonic balance simulation is
selected and you click the >>Add >> button, the following dialog appears:

This additional check is made only when a single trace is selected. When several traces are selected, the check for the
type of data being plotted is more general.

  

 Editing Traces
 
Trace options enable you to choose different trace formats and change trace attributes. If the trace is
generated from an equation, you can also edit the equation.
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The Trace Options dialog box is used to modify existing traces. Any changes made from this dialog box
will only affect the currently selected trace. To change the options for all subsequent traces, refer to
Setting Trace Preferences.

Note
Trace options for the chosen trace type are displayed automatically. If the trace options do not seem correct, click the
Trace Type tab, click the button corresponding to the type of trace you want, then reselect the Trace Options tab.

To edit trace options:

Double-click on the trace or select the trace and choose Edit > Item Options.1.
The Trace Options dialog box appears.2.

Select the Trace Type tab and click the button above the desired trace type.3.
The suggested plot-trace combinations are:
Plot Type Trace Types

Rectangular and Stacked Any type

Polar Linear and Scatter

Smith Charts Linear and Scatter

List None. Data is formatted from Plot Options

You can keep the Auto trace type and still edit the attributes of the trace. Generally, the correct4.
trace options will be displayed automatically. If you are not sure about the trace type or options,
perform the following steps:

Click the Trace Options tab followed by the Auto tab.
Note the trace type shown in the Auto tab.

The pattern, thickness, and color of a trace can be changed for all trace types except scatter. To5.
modify a trace line, make the following selections:

Click the Trace Options tab followed by the tab that matches the trace type.
Select a line pattern from the Type list.
Select a line thickness by using the scroll bar or entering a value into the Points field.
Click the Color bar, select a new color, then click OK.

In addition to editing the trace of a  histogram, and you can also fill the histogram with a pattern.6.
The color of the fill will be the same as the trace color. To fill a histogram:

Click the Trace Options tab followed by the Histogram tab.
Enable Use Fill Pattern.
Click the Pattern bar, select a fill pattern, then click OK.

 The type and number of symbols shown on a trace can be changed. Symbols are used with7.
linear, scatter, and sampled traces to identify the data points that were measured during a
simulation. To modify the frequency of symbols (for linear traces only), make the following
selections:

Click the Trace Options tab followed by the tab that matches the trace type.
For linear traces, symbols can be displayed for some or all data points. Enable Auto Space
Symbols (symbols are added for a subset of data points, selected to avoid overlap on the
screen), or Place Symbols at all Data Points (symbols are added for all data points,
regardless of overlap), or No Symbols.
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Select a symbol from the Symbol Type list.
Click OK.

The Data Display enables you to change the text properties and numeric format used in bus8.
traces. This is done by clicking the Trace Options tab followed by the Bus tab and making the
following selections:

Select a format for the data from the Format list. The choices are:
Auto A default format is automatically chosen based on the data to be displayed. 
Dec Numbers are displayed in decimal (base 10). 
Hex Numbers are displayed in hexadecimal (base 16). 
Octal Numbers are displayed in octal (base 8). 
Binary Numbers are displayed in binary (base 2). 
Select a font from the Font Type list.
Click the Text Color bar, select a color, then click OK.

The Data Display trace labels are disabled by default. Trace labels are added to the display for9.
linear and digital traces with subtraces (such as the curve tracer display) or plots with more than
one independent variable along the x-axis.

To turn on trace labels, do the following:
Click the Trace Options tab followed by the tab that matches the trace type.
Select Display Label.

Data Display also provides options for displaying swept data (subtraces). These options are10.
controlled by using the checkboxes in the  Automatic Sequencing section of the Trace Options
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dialog box. For more information, refer to Setting Trace Preferences.
When you have finished editing the trace, click the OK button to close the Trace Options dialog11.
box and save the changes.

  

 Deleting Traces
To remove a trace from a plot, do the following:

To delete a single trace, single-click on the trace. For multiple traces, hold the Shift key down1.
and single-click on each trace of interest.
Press the Delete key or choose Edit > Delete.2.

Sometimes it is difficult to select a trace from a plot with multiple traces because the traces overlap. If
you have trouble selecting a trace, use the steps listed below:

Double-click on the plot.1.
The Plot Traces & Attributes dialog box appears.2.
Under Traces, select the variables used to generate the trace.3.
Click Delete.4.
Click OK to dismiss the dialog box and delete the trace.5.

  

 Setting Trace Preferences 
Trace preferences set the default trace properties and determine how traces will appear when inserted
onto a plot.
Any changes made to the preferences will only affect subsequently created traces. To change an option
for an existing trace, make the change using the Trace Options dialog box.
To save and reuse preference settings, you can create a preferences file that can be read by the data
display. For more information on how to create and use such a file, refer to Setting Data Display
Preferences (data).

To set trace preferences, use the following steps:

Choose Options > Preferences.1.
The Preference dialog box appears.2.
Click the Main tab. Set the trace line and symbol preferences by making the following selections:3.

Select a line pattern from the Type list.
Select a line thickness by using the scroll bar or entering a value into the Points field.

Click the Bus tab. Set the bus trace text and numbering preferences by using these steps:4.
Select a format for the data from the Format list. The choices are:
Auto A default format is automatically chosen based on the data to be displayed.
Dec Numbers are displayed in decimal (base 10).
Hex Numbers are displayed in hexadecimal (base 16).
Octal Numbers are displayed in octal (base 8).
Binary Numbers are displayed in binary (base 2).
Select a font from the Font Type list.
Click the Text Color bar, select a color, then click OK. 

Click the Symbols tab. Set the label and symbol preferences by doing the following:5.
If you want to display labels, enable Display Label.
Select Display Arrowheads On Spectral Traces if you want arrowheads to appear on the
measured data points on spectral traces.
If you want symbols to appear on the measured data points on linear traces, select Auto
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Space Symbols (symbols are added for a subset of data points, selected to avoid overlap on
the screen), or Place Symbols at all Data Points (symbols are added for all data points,
regardless of overlap). The default setting is No Symbols.
Select a symbol type from the Symbol Type list. This is the default symbol for linear, scatter,
and sampled traces.

Click the  Histogram tab and set the histogram fill preferences by doing the following:6.
Enable Use Fill Pattern.
Click the Pattern bar, select a fill pattern, then click OK.

Click the  Parameter Sweeps tab and set the options that control the appearance of swept data7.
(subtraces). The  Automatic Sequencing options are:

Line Type - Overrides the default Line Type of the trace and automatically uses different line
types for each sweep of the data.
Symbol Type - Overrides the default Symbol Type of the trace and automatically uses a
different symbol for each sweep of the data.
Line Color - Overrides the default Line Color of the trace and automatically uses different
colors for each sweep of the data.
One or all of the Automatic Sequencing options described above can be enabled at any one
time. If all three options are selected, the order in which they are sequenced is Line Type,
Symbol Type and Line Color.

Note
The Automatic Sequencing options only apply to linear data. If you check more than one option, you will not
see sequencing for the next option start until you have exhausted the previous option. There are many line
and symbol types. Be aware that if you check all three options, trace color won't start to change until over a
hundred subtraces exist, which is not a practical configuration.

When you have finished setting preferences, click the OK button to close the Preference dialog8.
box and save the changes.

  

 History Traces
History traces enable you to perform a series of sequential simulations and have the resulting traces
conveniently displayed in a single Data Display window.

You can turn trace history on, pause it, or turn it off completely. You can also have history mode
enabled on some traces or plots, and disabled on others.

To enable history traces, select the plots or traces for which you want history traces gathered and
then:

Choose History > On in the Data Display Window
OR
Right-click and select History On from a popup menu

Note
If no plots and/or traces are pre-selected when you choose History > On in the Data Display window, history
mode is enabled on all plots and traces in the window.

When history mode is enabled, an indicator appears at the top right hand corner of the plot and at the
end of the axis label. The indicator on the plot is green when history is being gathered and red when
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history is paused. The indicator at the end of the axis label does not change color.

In history mode, the most recent data collected is represented by a thicker trace, and all previous
traces become thinner.

To pause the gathering of trace history, choose History > Pause from the Data Display window menu.

To disable history traces, choose History > Off from the Data Display window menu. This command
disables history mode and clears all existing history traces in the Data Display window.

You can change the default number of history traces displayed using the Preference dialog box. Choose
Options > Preferences in the Data Display window, and use the History Traces area in the Main tab
to change the number of traces.

Note
History traces are available to you as display only, and only for the duration of the session. Unlike the active trace, you
cannot place markers on history traces, edit or save them.

  

 Memory Traces
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Memory Traces are primarily used in Advanced Design System tuning. For more information on using
memory traces, see Tuning, Optimization, and Statistical Design (optstat).
  



Advanced Design System 2011.01 - Data Display

62

 Equations
Equations perform complex mathematical operations on data. You can display equations results on
data display plots, enabling you to analyze information in various ways.

This section describes how to write equations and how to display the results. It includes examples of
how to use some of the mathematical expressions that are in Advanced Design System. A reference of
the functions that are available can be found online, it can be accessed from the Equations dialog box.
 

Equations can be simple or very complex. An equation can include:

Mathematical expressions and operations
Functions
Other data display equations
Dataset variables
Dataset information
Marker labels

 The rules for writing expressions are minimal:

Equations are case-sensitive
Equation names cannot start with a digit
All functions must be completed using the given syntax
Parentheses are used to define order of operation
Reserved names cannot be used as equation variables. For example, you cannot use mag as the
variable mag=[1::3]. Instead, it would need to be used as mymag=[1::3] or something similar.

  

 Inserting Equations 
 To insert an equation on the data display:

Click the Equation button from the palette or choose Insert > Equation.1.
Position the pointer on the display area and click the mouse. The Enter Equation dialog box2.
appears.
 

  Enter an equation with the equation variable name on the left side and the expression on the3.
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right. A sample equation is shown below.

The expression can include any of the items in the previous list. Note that the Dataset name is
not required if the Dataset variable is included in the default dataset.
Click the Functions Help button for an alphabetical list of links to the available measurement
functions. Click the Index tab in the left-hand frame of the Measurement Expressions
documentation for an optional method of scrolling through the list of functions.

Note
Only the functions described in the " Measurement Expressions" documentation should be used to write Data
Display equations.

  To add a dataset variable to the equation, position the cursor in the equation where you want to4.
insert the variable.
Select the dataset name from the list box.5.
A list of variables in the dataset is presented. Select a variable from this list and click Insert.6.
To modify the display properties of an expression, click Equation Properties. For more7.
information, refer to Editing Text (data).
Activate the Show Hierarchy checkbox to display the dataset variables in a tree format. For more8.
information, refer to Using the Dataset Browser (data).
Click the Manage Datasets button to locate a dataset that is not available in the current9.
workspace. For more information, refer to Dataset Aliasing (data).
Click the Variable Info button to access the Browse Data dialog box. If you click a dataset10.
variable in the list box of the Browse Data dialog box, detailed information about the dataset
variable is displayed on the right-hand section of the dialog. For more information, refer to
Viewing Variable Information.
When the equation is complete, click OK.11.

Note
If you entered an equation incorrectly, a warning message will appear and the equation identifier, Eqn, is displayed in the
color red (if an equation is correct, this is displayed in the color black).

    

 Shortening Variable Names

When using variables in the default dataset, the dataset variable names can be shortened to make an
equation easier to read, as long as each name remains unique. For example, if the variable is entered
as:
Curve_Tracer.Sweep1.DC1.DC.IC.i

If this variable is in the default dataset, you can erase everything from the last period back and keep
IC.i

If you want to use a variable with the same name, but from another dataset in the workspace, you
cannot delete part of the name of either variable. Variable names must be unique.

If you enter data from datasets that are outside the workspace, the full file path is entered. You may
want to keep the full path or you can erase the part of the file path that is common with the current
workspace.

   

  Viewing Data From Multiple Datasets
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The default dataset list only allows you to refer to a single dataset. If you have several equations you
can easily change the referenced datasets by defining string variables with a dataset name and
referring to the string variable in the equations. For example:

MeasuredData="measured"

MeasS21=db\($MeasuredData..S\(2, 1\)\)

DiffS21=MeasS21 − SimS21

SimulatedData="simulated"

SimS21=db\($SimulatedData..S\(2, 1\)\)

 Inserting Conditional Expressions

DDS Equation editor also allows you to enter conditional expressions. You can make use of if then else
statement as shown in the following example:

if ( argument > 1 ) then cmplx(0,0) else b1 endif

Note
The data type returned from "if" statement must be of same type to display it correctly. This can be done by using the
"cmplx()" function to return the 0 data.

  

 Viewing Equation Results
Equation results can be plotted or displayed in a list. You treat results like any other data. You can
apply markers, edit the format, or use the results of an equation within another equation.

To view the results of your equation:

Click the Equation button on the palette or choose Insert > Equation.1.
Position the pointer on the display area and click the mouse to display the Enter Equation dialog2.
box.
Select Equations from the Datasets and Equations list.3.
Select the equation variable and click the Insert button.4.
If the equation is entered incorrectly, an error indication is displayed. Some types of equation
errors cause the equation ( Eqn ) identifier on the Data Display to be highlighted in red. Other
errors will cause the error dialog box to appear. This dialog box provides specific information
about the error.
The default trace type for the chosen data will be used. If you want to verify or change the trace5.
type, click Trace Options and proceed to edit the trace.
Click OK to dismiss the dialog box and display the equation results.6.



Advanced Design System 2011.01 - Data Display

65

Equation results can also be displayed in text objects. For more information refer to Embedding
Equations in Text Objects. (data)

  

 Working with Multidimensional Data
  It is not uncommon to sweep more than one parameter in a simulation. Data from such simulations
is stored as multidimensional data. If you want to perform calculations on, or display only portions of
the data from such simulations, you need to use equations to select the subsets of data.

The curve tracer example is used to illustrate how to do this. The example is under the Examples
directory in the MW_Ckts subdirectory. From this subdirectory, open the workspace LNA_wrk and then
open the Curve_Tracer schematic that is part of this workspace.

To open the data display, from the curve tracer schematic window, choose Window > Open Data
Display and select Curve_Tracer.dds.

Refer to the schematic. In this example the base current, IBB, and the collector-emitter voltage, VCE
are swept in this manner: IBB is set to 5 mA, and VCE is swept from 0V to 3 V in 0.1 V steps. At each
0.1 V increment, IC is calculated and stored in the dataset. When this sweep is complete, IBB is
increased to 5 mA, VCE is swept from 0V to 3V, and at every 0.1 V increment IC is measured and
stored in the dataset. This is repeated until IBB equals 30 mA; a final sweep of VCE is performed and
the simulation is complete.

Refer to the data display. The curve tracer is the entire collection of IC data points. This data is stored
in the dataset, and the structure of how data is stored is described next.
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Certain measurements, such as EVM in a DSP schematic window, treat each sweep point as a separate
simulation and returns a single point of data. Each point of data contains the swept variable,
simulation results, and an index of zero.
To display such data, create an expression such as my_evm = E [ : : , 0] to extract the zeroth index of
the swept expression.

   

  Data Structure

Based on the simulation sweeps, there are six values for IBB and 31 values for VCE. The index for IBB
is 0-5, the index for VCE is 0-30. For each of these combinations of VCE and IBB, IC was calculated
and stored in the dataset.

It is possible to select a single point of data or a sequence of data. The next section describes how to
access portions of data using indices.
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 Accessing Data

Data is accessed by index values. The equation below returns the value of IC when VCE =0V and IBB
=20 mA.

Type the equation and use a list to display your results. For information on how to enter equations,
refer to Inserting Equations. For information on how to display equation results, refer to Viewing
Equation Results.

For this equation, the order of the indices did not matter, but in general it does. The next section
describes index order.

   

  Index Order

Data is retrieved by the index values. The index order is critical to returning intended data, and it is
based on how the simulation is set up. In the curve tracer simulation, the Parameter Sweep item
references the DC Simulation item, and the DC simulation parameter ( VCE ) is swept based on the
parameter-sweep parameter ( IBB ). The index order is outermost to innermost, so the index for IBB
precedes the index of VCE.

Try retrieving other data points, such as:

x1=IC.i[1,0]
x2=IC.i[0,1]
x3=IC.i[1,30]
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View the results in lists and compare your results to the data structure illustration.

  

 Accessing Sequences of Data

You can access subsets of data using indices. You can either specify the range, or use wild cards.
For example, to display only the trace for IBB = 20mA, type as an equation:

IBB20=IC.i[3,::]

Add IBB20 to the curve tracer plot to view the results.

The characters :: in the equation are the wildcard. In this equation, the wildcard substitutes for a VCE
index value, so all values of VCE are used and the entire trace of data is returned.

To display only a portion of the trace, use a sequence:

The data in the 10th through 20th elements are displayed. The default increment is 1, so this
sequence could also be written as 10::20. If you want to skip data points within the sequence, set the
increment to a value larger than one.
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Note
Try setting this trace to a Scatter trace type, then insert different increment settings in the equation to view the effects of
the increment parameter.

To display a portion of several traces, use two sequences:

IBB20=IC.i[3::5,10::20]

Note the results on the curve tracer plot.

  

 Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:

VCE5=IC.i[::,5]
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This example returns the values of IC where VCE = 0.5V.

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to
the new plot. The axes on this plot are different from the curve tracer. VCE is plotted along the y axis
as a function of IBB, which is plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:

VCE5=IC.i[5]

The wildcard in the first position is assumed.

  

 Plotting Multidimensional Data

When you plot multidimensional data, the x-axis depends on whether the data is plotted using a single
index value or using the wildcard (::) to select all index values.

The what() function returns the dimensions in the dataset entry and the number of points in each
dimension. The following shows that the dimensions in BudGain1 are Component, X, and freq.

The following shows multidimensional data plotted using a single index value (0) for frequency:
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Since frequency is a single index value, the x-axis value shifts left to the next dimension, which is X in
this example.
The following shows the same multidimensional data plotted using the wildcard to select all index
values for frequency:

Since frequency is all index values, the x-axis value is frequency. In this example, frequency was a
single value so you may have expected the same results as shown using a single index value.
However, the plotting routine does not make a distinction between the case where the wildcard
represents one index value or multiple index values.

  

 Working with Swept S-parameters
  If you want to access subsets of swept S-parameters, you need to use both index notation and S-
parameter notation. This section describes the various combinations and the results that are returned.

  

 Setting up an Example

If you want to have an example to work with, set up and perform the simulation described here.
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Otherwise, skip to the next section.

This example adds a parameter sweep to the amplifier schematic in the SweptSparams_wrk workspace.

From the Main window, click the Examples directory.1.
Select Tutorial.2.
Select SweptSparams_wrk.3.
Make a copy of the SweptSparams_wrk workspace.4.
Open the copy of SweptSparams_wrk.5.
Open the schematic amplifier.6.
Add a swept parameter by modifying the voltage source using a Var Eqn Data item and a7.
parameter sweep item, as shown below.

Rerun the simulation. The simulation will run in this manner: Vbias is set to 3V and an S-8.
parameter simulation is performed at each frequency specified in the S-parameter simulation item
and the S matrixes are stored in the dataset; Vbias is set to 3.9 V and another set of S-parameter
simulations are performed and stored in the dataset; this continues until Vbias equals 2.0 V, when
a final set of S-parameter simulations are performed and the entire simulation is complete.
When the simulation is complete, open a new Data Display window.9.
Set the default dataset to amplifier.10.
Insert a rectangular plot and add S(2,1) to the plot. The entire collection of S(2,1) data points11.
that were calculated for each frequency point and for each value of Vbias is displayed.

The next section describes how the data is stored in the dataset.

  

 Data Structure

Based on the simulation sweeps, there are eleven values for Vbias and 200 values for freq. The index
for Vbias is 0-10, the index for freq is 0-199. For each of these combinations of Vbias and freq, an S
matrix was calculated and stored in the dataset.
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Index order is the same as described in Index Order. That is, the outermost index is first, innermost is
last. In the example above, the first position is the index of Vbias, the second is for freq.

  

 Accessing Data

You can access S-parameters using indices. The equation below returns S21 calculated for Vbias =2.9

V and freq = 5 MHz:

myS21=S21[1,0]

Type the equation and use a list to display your results. For information on how to enter equations,
refer to Inserting Equations. For information on how to display equation results, refer to Viewing
Equation Results.

The equation below returns S21 at all frequencies for a single value of Vbias ( Vbias =2V):

S21at2V=S21[10,::]

Add this result to a plot. The wildcard :: is used to substitute for a freq index, so all values of freq are
returned, enabling you to display an entire trace of S21 results.
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To display only a portion of the trace, use a sequence:

The data in the 50th through 199th elements are displayed. The default increment is 1, and the
sequence could be written as 50::199. If you want to skip data points within the sequence, set the
increment to a value larger than one.

Hint
Try setting this trace to a Scatter trace type, then insert different increment settings, for example replace 1 with 20, to
view the effects of the increment parameter.

To display a portion of several traces, use two sequences:

S21block=S21[2::10,90::140]

Add this to the plot and note the results.
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 Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:

column=S21[::,80]

This example returns S21 for every value of Vbias at the frequency with index 80.

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to
the new plot. The axes on this plot are different from the curve tracer. S21 is plotted along the y axis

as a function of Vbias, which is plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:

column=S[80]

The wildcard in the first position is assumed.

   

  Working with an S Matrix
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S-parameters are stored in an S matrix. In general, you will probably want to work with a specific S-
parameter and not the entire matrix. You can, however, access an entire matrix. If you do not specify
an S-parameter, an equation using S returns the entire S matrix:
myMatrix=S[1,0]

Note
If ellipsis points appear in the list of data, enlarge the list by selecting the list and dragging a handle horizontally until all
values are displayed correctly.

You can also use indices in this way without specifying an S-parameter and return the S matrix at each
point:
manyMatrices=S[2::5, 80::90]

Use a list to display your results. Use the scroll buttons to browse the entire list of data. As you can
see, a large amount of data is returned.

  

 Viewing Variable Information
   Use the what function to view information about a variable, including:

Independent variables
Number of data points
Matrix size
Data type, such as real or complex

If the variable contains a single number or a one-dimensional sequence of numbers (like a row or
column) it is termed Scalar. If the data is two dimensional, it is termed a Matrix and the size of the
matrix is given. Examples of two variables from the swept S-parameter example, Vbias and the S
matrix, S, are shown below. For details about these variables, refer to Setting up an Example.

   

  Finding an Index

The amount of data in this simulation is two dimensional and relatively small, and it is not difficult to
determine the swept parameter values that correspond to indices. For more complex problems, you
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can use the find_index() function. The find_index() function returns the index that corresponds to a
data value. For example, in the Curve_Tracer example, VCE is a scalar that contains 61 points of data.
The equation below returns the index when VCE is 3 V:

The find_index() function works only on scalar data. VCE is specified using indices in order to present it
in scalar format.

   

 Using Markers in Equations 
  You can add marker labels to equations and perform operations on marker data. The operation is
performed on the dependent marker data.

To add a marker to an equation:

Click the Equation button on the palette or choose Insert > Equation.1.
Position the pointer on the display area and click the mouse.2.
The Enter Equation dialog box appears. Type the equation.3.
At the point where you want to add the marker, choose Equations __ from the Datasets and4.
Equations __ list.
Select the marker label and click Insert.5.
Complete the equation, then click OK.6.

You can treat markers like any other variable in an equation.

Note
If you change the marker label (which is accomplished by selecting the marker and choosing Edit > Item Options), you
must edit your equations by deleting the old marker label and entering the new marker label.

   

 Using Independent Marker Data 

You may want to retrieve the independent data in a marker. You can do this using the indep function.
For example:
myequation=indep(m1)
where m1 is the marker label. You can also nest this within another function.

Markers on polar plots and Smith charts return data in complex format. You may want to work with
only the imaginary portion of the number, which you can retrieve using the imag function. The
illustration shown next shows a Smith chart, the marker applied to a trace, the equation used to
isolate the imaginary component, and a list to verify the equation is correct.
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 Generating a Histogram after Monte-Carlo Analysis
The example in this section demonstrates a simple histogram using data from the Tutorial/yldex1_wrk
example. The example simulates the frequency response of an impedance transformer, with
component values varied during a yield analysis. For more information on generating a histogram,
refer to Using Statistical Design (optstat).
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 Simple Histogram using data from the Tutorial/yldex1_wrk Example

The first plot in Simple Histogram using data from the Tutorial/yldex1_wrk Example above shows
all of the dB(S21) curves.
The second plot shows the distribution of dB(S21) at one particular frequency, specified by the
"freq_index" equation.
The S21[::,freq_index] syntax selects the S21 values for all Monte Carlo iterations at the
"freq_index" frequency.
The NumBins variable just sets the number of histogram bins.

  

 Using Predefined Equations
Data Display has a set of predefined equations that you can use to display and document current data
properties such as default dataset name and path.

The following table lists the predefined equations available:

Predefined Equation Name Description

Default_Dataset_Name The current default dataset name. This name does not include the ".ds" extension

Default_Dataset_Path The full path to the directory that contains the default dataset

Default_Dataset_Modified_Time The time the default dataset file was last modified

Default_Dataset_Modified_Date The date the default dataset file was last modified

Default_Dataset_Size The size in bytes of the default dataset

DDS_File_Name The current DDS file name without the ".dds" extension

DDS_File_Path The path to the directory that contains the current DDS file

DDS_File_Modified_Time The last time the DDS file was modified

DDS_File_Modified_Date The last date the DDS file was modified

DDS_File_Size The size in bytes of the DDS file

You can display dataset information in two ways, using either a text object or a list.
To display dataset information in a text object refer to Embedding Dataset Properties in Text Objects.
(data)

To display dataset information in a list...

Select List from the palette or choose Insert > Plot, then click the mouse on the page to place1.
the plot and display the Plot Traces & Attributes dialog box.
Select List in the Plot Type tab.2.
From the Datasets and Equations dropdown menu select Predefined Equations.3.
Use the dialog box to select and add data properties to the display.4.
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 Sliders
The slider plot simplifies the process of accessing individual sweeps of swept data by automatically
generating an equation that contains the data index for the desired sweep.

The format of the generated equation is: <MarkerName>_<SweepName>_index

Where

MarkerName is the name of the marker that is automatically added to the slider during plots
creation.
SweepName is the name of the swept data of interest.

This equation can be used to select a specific sweep of swept data.

 Inserting Slider
Follow the steps below to insert a slider plot:

From the DDS window, choose Insert > Slider.1.

Position the pointer on the display area. A rectangle image is attached to the pointer which2.
indicates the position and size of the plot.
One you place the Slider anywhere in display are, the Slider Plot Trace & Attributes dialog box3.
appears.
Select the trace that contains the swept data that you want the slider to operate on and click4.
>>Add >> button to add it to the Trace list.
Select the data to sweep with the slider.5.



Advanced Design System 2011.01 - Data Display

82

Select the Plot Options tab to set up the plot. Enter the title and define scaling data accordingly.6.
For more details on how to change plot options, see Editing Plots (data).
Click OK to insert the slider plot and to create the "m1_IBB_index" equation.7.

Once the slider has been created you can use the index equation to select a specific sweep of the
swept data. In the above example index equation is used to create a trace that shows an individual
sweep of the sweep curve trace data. The data of interest, in this case IC.i, contains one sweep of IBB
and the inner most data of VCE. The slider equation has been applied to the IBB sweep of the IC.i
data. The equation to plot this data looks like this "IC.i[m1_IBB_index,::]". As you move the marker
"m1" on the slider the blue trace will move up and down along the plot as the slider index equation is
updated with each marker move.
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 Annotating the Data Display
Designs can be better documented by making annotations on the display. The Data Display includes
drawing tools that enable you to annotate the display by inserting text and drawing objects.

  

 Inserting Text
 

 Adding Text

To add text to the Data Display:

Choose Insert > Text or select Text from the palette.1.
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Click the mouse on the display page to place the text. The insertion point is marked by a red2.
cursor.
Type the text.3.
When you are finished, click the End Command button on the toolbar or choose Edit > End4.
Command.

  

 Embedding Equations in Text Objects

You can display equation results as well as equation names in text objects.

Any named equation can be embedded in a text object by preceding its name with the "@" character,
for example "@freq". Use either the onscreen editor or the Enter Text dialog box to embed or edit
equations in texts.

To embed equations in the text using the onscreen editor...

Choose Insert > Text or select Text from the palette.1.
Single-click the mouse on the display page.2.
Type the text and place the "@" character before any equation name.3.
When you are finished, click the End Command button on the toolbar or choose Edit > End4.
Command.

To embed equation results in the text using the Enter Text dialog box...

Choose Insert > Text or select Text from the palette, then double click the mouse on the page1.
to place the text and display the Enter Text dialog box.
Select the Select Data and View Warnings/Errors checkbox to display the dataset browser.2.
Insert an equation in the text by double-clicking it or by selecting its name from the dataset3.
browser and clicking the Insert button. The equation name will be added to the text field
preceded by the "@" symbol. Click OK.

When you deselect the text object, the equation results are automatically evaluated and displayed in
the text. Up to three data items, separated by commas, are displayed for each equation, followed by
"..." if more data items are available.
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To re-activate the onscreen editor, single-click the text. The text is highlighted and displayed in its
original form, showing the equation name.

To display the equation name and not the calculated result, add a backslash before the "@" symbol in
the text editor. For example: "@freq".

If an error occurs, or the equation is not found, the equation name is displayed in the text instead of
the equation result.

Note
Embedded equations may generate errors and warnings, which appear in the Equations Warnings/Errors area in the Enter
Text dialog box.

  

 Embedding DDS File and Dataset Properties in Text Objects

Data Display has a set of predefined equations containing current DDS file and dataset information
such as default dataset name and path. These equations enable you to embed dataset information in
text objects, simplifying documentation.

The following table contains the list of predefined equations available:

Predefined Equation Name Description

Default_Dataset_Name The current default dataset name. This name does not include the ".ds"
extension

Default_Dataset_Path The full path to the directory that contains the default dataset

Default_Dataset_Modified_Time The time the default dataset file was last modified

Default_Dataset_Modified_Date The date the default dataset file was last modified

Default_Dataset_Size The size in bytes of the default dataset

DDS_File_Name The current DDS file name without the ".dds" extension

DDS_File_Path The path to the directory that contains the current DDS file

DDS_File_Modified_Time The last time the DDS file was modified

DDS_File_Modified_Date The last date the DDS file was modified

DDS_File_Size The size in bytes of the DDS file

You can embed dataset information in the same way you embed other equations in text objects:

Choose Insert > Text or select Text from the palette, then double click the mouse on the page1.
to place the text and display the Enter Text dialog box.
Select the Select Data and View Warnings/Errors checkbox to display the dataset browser.2.
In the dataset browser dropdown menu select Predefined Equations.3.
Insert the desired equation in the text by double-clicking it or by selecting its name and clicking4.
the Insert button. The equation name will be added to the text field preceded by the "@" symbol.
Click OK.

  

 Editing Text
The text, fill, and outline of a text box can be easily changed by using the Enter Text dialog box. Any
changes made from this dialog box will only affect the currently selected text box. To change the
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options for all subsequent text entries, refer to Setting Text Preferences.

To edit text:

Double-click on the text or select the text and choose Edit > Item Options.1.
The Enter Text dialog box appears. 2.
Change the text as desired.3.
To change the text format, click the Properties button.4.
To change the font   properties:5.

Select a font from the Font Type list.
Select a font size from the Font Size list.
Click the Text Color bar, select a new color, then click OK.

The text is enclosed in a text frame. To display the outline of this frame, enable Draw Outline.6.
To edit the outline:

Select a line pattern from the Type list.
Select a line thickness either by using the scroll bar or entering a value into the Points field.
Click the Color bar, select a new color, then click OK.

To fill the background of the frame, enable Use Fill Pattern. To edit the fill:7.
Click the Color bar, select a new color, then click OK.
Click the Pattern bar, select a pattern, then click OK.

Click OK to close the Edit Text Properties dialog box.8.
Click OK to close the Enter Text dialog box and accept the changes.9.

  

 Deleting Text
To remove a text frame, do the following:

To delete a single text frame, single-click on the frame. For multiple frames, hold the Shift key1.
down and single-click on each frame of interest.
Press the Delete key or choose Edit > Delete.2.

  

 Setting Text Preferences 
Any changes made to the preferences will only affect subsequently created text. To modify existing
text, make the change using the Enter Text dialog box.

To save and reuse preference settings, you can create a preferences file that can be read by the data
display. For more information on how to create and use such a file, refer to Setting Data Display
Preferences (data).

To set preferences:

Choose Options > Preferences.1.
The Preference dialog box appears. Click the Text tab.2.
Set the text preferences by doing the following:3.

Select a font from the Font Type list.
Select a font size from the Font Size list.
Click the Text Color bar, select a new text color, then click OK.

The appearance of text box outlines is set by using these selections:4.
Enable Draw Outline.
Select an outline pattern from the Type list.
Select the outline thickness either by using the Thickness scroll bar or entering a value into
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the Points field.
Click the Color bar, select a new color, then click OK.

Text box fill preferences are set as follows:5.
Enable Use Fill Pattern.
Click the Color bar, select a new fill color, then click OK.
Click the Pattern bar, select a fill Pattern, then click OK.

Click OK to close the Preference dialog box and accept the changes.6.

  

 Inserting Objects
The commands used to add graphical objects to your display are found on the Insert menu as well as
on the palette.

To insert an object, do the following:

Click the button on the palette that corresponds to the desired shape (Circle, Rectangle, etc.) or1.
choose the shape from the Insert menu.
Position the pointer on the display page and click the mouse.2.

For lines, move the pointer until the line is the desired length, then click the mouse.
For rectangles and circles, move the pointer until the object is the desired size, then click the
mouse.
For polylines and polygons, continue adding segments by positioning the pointer and clicking
the mouse.
To complete a polyline, double-click the mouse. For a polygon, draw the second to last
segment and then double-click the mouse. The last segment is added to make a closed
region.

The object drawing mode remains active, allowing you to place other objects of the same type by3.
moving the pointer and clicking the mouse.
If you are finished, click the End Command button in the toolbar or choose Edit > End4.
Command. 

  

 Editing Objects 
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You can edit object properties such as line width, line thickness, and color. For 2-D objects, you can fill
the area with a pattern and color.

You can also edit objects by moving them, changing their size, or by using delete, cut, copy, and paste
commands. For more information on these functions, refer to Data Display Basics (data).

Any changes that you make will only affect the currently selected object. To change properties for all
objects added subsequently, refer to Setting Object Preferences.

Objects are edited using the following steps:

Double-click on the object or select the object and choose Edit > Item Options.1.
The edit dialog box appears.2.
Lines and object outlines are edited using these selections:3.

Select a line pattern from the Type list.
Select the line or outline thickness either by using the Thickness scroll bar or by entering a
value into the Points field.
Click the Color bar, select a new color, then click OK.

An object's fill can be changed using these selections:4.
Enable Use Fill Pattern.
Click the Color bar, select a new fill color, then click OK.
Click the Pattern bar, select a fill Pattern, then click OK.

Click OK to close the dialog box and accept the changes.5.

  

 Deleting Objects
To remove an object, do the following:

To delete a single object, single-click on the object. For multiple objects, hold the Shift key down1.
and single-click on each object of interest.
Press the Delete key or choose Edit > Delete.2.

  

 Setting Object Preferences      
Object preferences determine how new graphical objects will appear when they are inserted onto a
display area.
Object preferences affect all objects created after the changes were made and saved. To change the
properties for an existing object, refer to Editing Objects.

To save and reuse preference settings, you can create a preferences file that can be read by the data
display, which can facilitate setting preferences. For more information on how to create and use such a
file, refer to Setting Data Display Preferences (data).

To set "Shapes" preferences:

Choose Options > Preferences.1.
The Preference dialog box appears. Select the Shapes tab. It is used to set the values for the2.
various shapes that DDS supports.
There are sub-tabs for each type of object. Move through the tabs and define your preferences.3.
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Lines and object outlines preferences are set using these selections:4.
Select a line pattern from the Type list.
Select the line or outline thickness either by using the scroll bar or entering a value into the
Points field.
Click the Color bar, select a new color, then click OK.

An object's fill preferences can be set by using these selections:5.
Enable Use Fill Pattern.
Click the Color bar, select a new fill color, then click OK.
Click the Pattern bar, select a fill Pattern, then click OK.

Click OK to close the Preference dialog box and accept the changes.6.

 
To set "Entry/Edit" preferences:

Choose Options > Preferences1.
Choose the Entry/Edit tab from the Preferences dialog box.2.
Data and Time format are used when DDS prints a date/time entry.3.
Set the Date and Time format of your choice4.
Drag and Move defines how may screen pixels you have to move the mouse before the drag5.
starts a move command. If you don't move the mouse this may pixels, its considered a mouse
click instead of a mouse drag.
The drag amount can be given only in "screen pixels"6.
Click OK to close the dialog box and accept the changes.7.
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 Setting Grid/Snap Preferences
In the Options menu of the Data Display window, select Preferences. In the Preferences window,
select the Grid/Snap tab, which is illustrated below.
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 Display

Under Display on the Grid/Snap tab, select Dots, Lines, or None. (None is selected by default; in
this case, the grid will not be visible on the Data Display window, but can still be used for aligning
objects.)

Use the Color selection tool to choose a color for the displayed grid.

In general it is best to use dark colors for dots and pale colors for lines. As the dot color and line color
are independent, it is best to make the color selection after making the choice of dots or lines.

 Spacing

Note
Under Spacing on the Grid/Snap tab, values entered for the X axis are also applied to the Y axis if the box labeled
"Automatically set Y=X when any X value is modified" is checked (as it is by default). Even if the box is checked, Y values
can still be set independently.

Select X and Y values for Snap Grid Distance (in inches). This determines how far apart on the
screen the displayed dots or lines will appear. The default distance for both X and Y is 0.125 inches.

Note
If the distance specified is so small as to make the grid appear very dense on the screen, the data display window will
hide the grid rather than allow it to make the window contents unreadable. To see the grid, zoom in on the window
contents, expand the window, or use a larger distance setting.

Select X and Y values for Snap Grid per Display Grid. This determines the number of grid points per
linear inch, relative to the number of displayed dots or lines per linear inch. The default setting for
both X and Y is 2 (that is, grid points occur twice as frequently along a given length as the display
indicates). Increase the value to add more grid points between the displayed grid markings. In the
illustration below, with X and Y set to 2, the red dots represent the displayed grid points and the
hollow circles represent the hidden grid points between them.

Note
The value of Snap Grid per Display Grid is required to be an integer in the range of 1 to 100.

 Active Snap Mode

Under Active Snap Mode on the Grid/Snap, use the checkbox to enable or disable grid snap mode.
(It is enabled by default.)
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Enabling snap mode does not, by itself, cause any existing object to align itself to the grid. Even when
snap mode is enabled, objects snap to the grid only when they are dragged.

Note
Grid/Snap mode can also be enabled or disabled without opening the Preferences window, by checking or unchecking
Snap Enabled on the Options menu of the data display. The same can be done using the relevant hot-key (which, by
default, is Ctrl-E).

  

 Adding Date and Time to a Data Display
You can add the current date and time to a data display using the AEL function date_time(). You can
add this (or any other AEL expression) to a data display using an equation, then display the results on
a plot. In the procedure below, date and time are displayed in a list.

Click the Equation button on the palette or choose Insert > Equation.1.
Position the pointer on the display area and click the mouse button.2.
The Enter Equation dialog box appears. Enter the equation as current_date_time=date_time()3.
. (Use any variable name on the left side of the equation and the AEL function on the right side of
the equation.) Click OK.

From the tool bar on the left side of the Data Display window, click the List button, move the4.
pointer into the display area of the window, and click.
In the dialog box that appears, select Equations from the Datasets and Equations drop-down list.5.
Select the variable (in this case, current_date_time) and click Add. Click OK.6.

Note this is not a date/time stamp, it is updated to reflect the current date and time.

Note
You can add variables to an ADS schematic to display current date and time, plus other design and system
information. For more information, see Schematic Capture and Layout (usrguide) documentation.
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 Markers
Markers enable you to read data values at specific points on a trace. They return the independent and
dependent values of the data.

Marker Types summarizes the types of markers available in Data Display:

Marker Name Description

Normal Returns value from any point on a trace

Delta Displays the difference between two markers

Offset Finds a fixed offset from a reference marker

Peak Finds the localized peak values of a trace

Valley Finds the localized valleys of a trace

Max Finds the data points that reflect the maximum data
values

Min Finds the data points that reflect the minimum data values

Line Displays all trace values at a specific independent value

For more information refer to Delta Mode, Offset Marker, Peak and Valley Markers,Line Markers and
Max and Min Markers.

 When a marker is inserted, the following items appear on the display page:

The marker symbol.
The marker readout, which returns the data at that point on the trace.
 Marker labels, one on the trace and one in the readout. This is helpful when you have multiple
markers displayed.

The figure below shows a marker inserted onto a trace and the data returned from that point on the
trace.

Markers can also be used in equations. For information refer to Using Markers in Equations. (data)

    

 Inserting Markers  
You can insert one or more markers onto a trace.

To insert a marker:
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Choose Marker > New <Marker Type> or select the appropriate marker from the Marker1.
toolbar.

The Insert Marker dialog box appears. Position the pointer on the trace where you want to insert2.
the marker and click.
The dialog box is automatically dismissed.3.

You can then drag the marker and move it to any position along the trace. An active marker readout is
displayed to help you position the marker.

The marker data appears next to the marker. To keep your plot uncluttered, enlarge the data display
window, select the marker readout text, and drag it off to one side of the plot.

  

 Moving Markers
There are three ways to move markers:

Drag the marker to any position along a trace. An active marker readout is displayed to help you
position the marker.
Select the marker and move it to the next or previous data point by:

Using the arrow keys on your keyboard
Using the arrow buttons on the Marker toolbar
Selecting Next Data Point or Previous Data Point from the Marker pulldown menu or from the
marker popup menu

Change the value and units of the independent variable in the marker readout. For more
information, refer to Editing the Marker Readout.

  

 Editing Markers
    
You can change the properties of an individual marker using the Edit Marker Properties dialog box.

Note
Any changes that you make will only affect the currently selected marker. To change the properties for all markers added
subsequently, refer to Setting Marker Preferences.

To edit a marker, double-click the marker or the marker readout to display the Edit Marker Properties
dialog box. The dialog includes four tabs, as described below.

 Main Marker Properties Tab
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Use the Main tab to:

Change the marker label text in the Marker Name field

Note
Markers can be used in equations by adding the marker label to an equation. Be aware that if you use a marker
label in an equation and then change the marker label in the Marker Name field, you must update your equation
with the new marker label.

Change the marker type in the Marker Type field
Select Delta or Offset mode in the Marker Mode field, or Off to deactivate those modes
Control the aperture size using the Peak/Valley Marker area
Select the reference marker in the Delta/Offset Marker area
Enter the relative offset value in the Delta/Offset Marker area
The check box Enable Sweep Index Equation allows you to create an equation that is the data
index of where the marker is currently located. The equation that is created has the following
form <marker name>_<sweep name>_index.

 Format Marker Properties Tab
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Use the Format tab to:

Select a readout format.
Select a complex format (for dependent values).
Specify the number of significant digits.
Select Smith Chart Values (type, complex format, and Zo).

 Symbol Marker Properties Tab

Use the Symbol tab to:

Select the size of the symbol.
Select the marker color.
Select the symbol type for normal and delta markers (the illustration above shows the available
types).
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 Font Marker Properties Tab

Use the Font tab to:

Select the font type, font size, and text color for the marker name.
Select the font type, font size, and text color for the marker readout text.

 Display Marker Properties Tab

Use the checkboxes on the Display tab to:

Choose whether or not the readout, symbol, and name for the marker will be displayed (at least
one of the three must be left visible).
Choose whether or not the various elements of the marker readout contents will be displayed.
Choose whether or not the readout for a marker will be moved on the data display window when
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the plot containing that marker is moved. (Note that this behavior is not saved between sessions,
and that default behavior is for the readout to move with the plot.)

  

 Changing Marker Type
You can change the type of an existing marker in one of two ways:

Double-click the marker or its readout and use the Edit Marker Properties dialog box to select a
different type of marker.
OR
Select the marker and right-click the mouse, then select a different marker type from the popup
menu.

  

 Deleting Markers
To delete markers, do the following:

To delete a single marker, single-click on the marker. For multiple markers, hold the Shift key1.
down and single-click on each marker of interest.
Press the Delete key or choose Edit > Delete.2.

  

 Setting Marker Preferences
Marker preferences set the default marker properties and determine the appearance of a marker when
it is inserted onto a plot.

Marker preference changes will apply to all markers created after the changes were made and saved.
To change properties for an existing marker, refer to Editing Markers.

To save and reuse preference settings, you can create a preferences file that can be read by the data
display. For more information on how to create and use such a file, refer to Setting Data Display
Preferences (data).

To set marker preferences, do the following:

Choose Options > Preferences to display the Preference dialog box.1.
Click the Marker tab to edit the marker preferences.2.
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There are five tabs under the Marker tab:

Main
Format
Symbol
Font
Display

 Marker Main Preferences Tab

Use the Main tab to:

Select the aperture width and height for a peak/valley marker.
Set the relative offset for an offset marker.

 Marker Format Preferences Tab

Use the Format tab to:

Select a readout format.
Select a complex format (for dependent values).
Specify the number of significant digits.
Select Smith Chart Values (type, complex format, and Zo).

 Marker Symbol Preferences Tab
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Use the Symbol tab to:

Select the size of the symbol.
Select the marker color.
Select the symbol type for normal and delta markers (the illustration above shows the available
types).

 Marker Font Preferences Tab

Use the Font tab to:

Select the font type, font size, and text color for the marker name.
Select the font type, font size, and text color for the marker readout text.

 Marker Display Preferences Tab
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Use the checkboxes on the Display tab to:

Choose whether or not the readout, symbol, and name for the marker will be displayed (at least
one of the three must be left visible).
Choose whether or not the various elements of the marker readout contents will be displayed.
Choose whether or not the readout for a marker will be moved on the data display window when
the plot containing that marker is moved.

  

 Marker Readout
A marker readout includes:

A label that matches the label on the marker
The value of the independent variable
The value of the dependent variable. Values from polar plots and Smith charts are displayed in
real and imaginary components; markers on Smith charts also display either impedance or
admittance. Values from rectangular and stacked plots are returned in scalar format.
The sweep value of the marker's position in the data
The marker type (displayed for all marker types except for Normal marker)

 

 Editing the Marker Readout

The independent value of the marker readout can be edited directly, thus avoiding the need to drag
the marker to a particular value. The following example illustrates the position of the independent
variable value and units.
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To edit the independent variable value:

Click the independent variable value and units portion of the marker readout. The text will turn1.
red.
Enter the new value and/or units. The marker indicator will move to the point nearest the entered2.
value. Conversions between understood units will be updated automatically.

Note
The units evaluator only understands a limited set of units. For instance, in the example shown above, usec is
understood as microseconds (i.e. 10e-6 seconds); however, micro secs is not.

  

 Delta Mode 
The difference between two markers can be displayed using delta mode. The readout of the selected
marker changes relative to the marker that you assign as the reference.

You can select any markers in a data display for comparison in delta mode. The markers can be on the
same trace, on different traces in the same plot, or on different traces in different plots. The delta
marker equation is:
delta = delta marker - reference marker

The following example shows two markers used in delta mode. Note that the marker in delta mode is
rotated. The reference marker is unchanged.
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To activate delta mode:

Hold the shift key and select the markers you want to display in delta mode. Be sure to include1.
the reference marker.

Hint
As an alternative to selecting markers, you can select the marker readouts.

Choose Marker > Delta Mode On or right click and select Delta Mode On from the popup2.
menu.
A dialog box appears listing the selected markers. Select one marker from this list to be the3.
reference marker.
Click OK.4.

To deactivate delta mode Choose Marker > Delta/Offset Mode Off or right click and select
Delta/Offset Mode Off from the popup menu.

You can also activate and deactivate delta mode using the Edit Marker Properties dialog box. For more
information refer to Editing Markers.

  

 Offset Marker
An Offset marker enables you to set a fixed offset from a reference marker on a linear trace contained
in a rectangular plot. When you move the reference marker, the Offset marker moves with it, keeping
the relative offset unchanged.

The Offset Marker snaps to the closest actual data point that matches the value you define in the Edit
Marker Properties dialog box. You can control which side of the reference marker the Offset marker will
reside.

The following example shows two markers used in offset mode. Note that the marker in offset mode is
rotated. The reference marker is unchanged.
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To activate offset mode:

Hold the shift key and select the markers you want to use in offset mode.1.

Hint
As an alternative to selecting markers, you can select the marker readouts.

Choose Marker > Offset Mode On or right-click and select Offset Mode On from the popup2.
menu.
A dialog box appears listing the selected markers. Select one marker from this list to be the3.
reference marker.
Click OK.4.

Note
When you activate offset mode in this way, the offset is set to the default relative offset. To change the default
offset, use the Preference dialog box. For more information refer to Setting Marker Preferences. If you need to set a
unique offset each time, activate offset mode using the Edit Marker Properties dialog box. For more information
refer to Editing Markers.

To deactivate offset mode use one of the following options:

Choose Marker > Delta/Offset Mode Off or right-click and select Delta/Offset Mode Off from
the popup menu.

You can also deactivate offset mode using the Edit Marker Properties dialog box. For more information
refer to Editing Markers.

Note
When you attempt to add an Offset marker on a trace or a plot that doesn't support this marker type, the marker is
automatically converted to delta marker and a warning message pops up. The warning will also occur if you change the
trace type or if the simulation results change the automatic trace type to an unsupported type.

  

 Peak and Valley Markers
Peak and Valley markers enable you to find the localized data peaks and valleys of a linear trace
contained in a rectangular plot.

Note
The value of each peak may be lower than the maximum data value for the entire trace, and the value of each valley may
be higher than the minimum data value for the entire trace. To find the minimum and maximum data values use the Min
and Max markers.
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You can insert and drag Peak and Valley markers like any other marker. These markers snap to peak
or valley points automatically, and you can then move them to the next/previous peak/valley in
different ways:

Use the arrow keys on your keyboard.
Use the arrow buttons on the Marker toolbar.
Select Next data point or Previous data point from the Marker pulldown menu or popup menu.

Note
When a Peak or Valley marker is placed on a trace or a plot that doesn't support this marker type, the marker is
automatically converted to a supported marker type (Max/Min) and a warning message pops up. The conversion
also occurs if the trace type is changed, either by you or by simulation results, to a type that doesn't support Peak
and Valley markers. Note that the markers are not automatically converted back to their original type even if the
data is restored to its original type.

  

 Peak and Valley Marker Aperture

A marker aperture enables you to selectively include or exclude data peaks and valleys.
The aperture is a box that surrounds the marker and is used to identify peaks. It reflects the
percentage of the maximum data range. To include smaller peaks/valleys, make the aperture smaller,
and to reject smaller peak/valley locations, make the aperture larger.

The following figures demonstrate the role of the marker aperture:

The first figure is an example of an invalid peak, because the data inside the aperture does not
form a peak (in a valid peak the slope of the data leading to the peak is positive and the slope of
the data trailing the peak is negative).

Reducing the size of the aperture (as shown in the next figure) makes the marker location a valid
peak.
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The aperture enables you to reject peaks that you are not interested in, an important capability with
signals that have many "noisy" peaks.

To change the aperture size...

Double click a Peak/Valley marker or its readout to display the Edit Marker Properties Dialog box.1.
Select the Main tab.2.
Use the Aperture Width % and Aperture Height % fields in the Peak/Valley Marker area to change3.
the width and height of the marker.
Click OK to save the changes and close the dialog box4.

To change the default aperture for all newly created Peak and Valley markers, refer to Setting Marker
Preferences. The new default aperture will apply to all markers created after the changes were made
and saved.

 

 Line Marker
A Line marker displays all trace values at a specific independent value. It will only be available in
Rectangular and Stacked Plots. It is taken from digital simulators which have a marker that you place
on the screen and it goes from top to bottom of the trace area and displays values of all the traces.

You can insert a line marker from the Menu item as shown:
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Figure: Menu Item for Line Marker

A new item is also added in the tool bar for quicker access to line marker:

Figure:Toolbar symbol for Line Marker

Line marker is displayed from top to bottom of the trace area and displays values of all the traces. The
readout contains: marker name, independent value and dependent values from all traces. Editing the
indep value in readout can move the line marker. Line marker supports drag, move, snapping as
normal marker does. Line marker’ properties can be changed like normal marker in marker dialog.

Special features of Line Markers:

Line marker is displayed from top to bottom of the trace area and displays values of all the traces.1.
The readout contains: marker name, independent value and dependent values from all traces.2.
Editing the indep value in readout can move the line marker.
Line marker supports drag, move, snapping as normal marker does. Line marker’ properties can3.
be changed like normal marker in marker dialog.

Line marker only supports the rectangular plot and stacked plot. When we insert the line marker4.
into other plots (such as, smith, polar, etc.), the following warning dialog shows up.
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Line marker can be inserted into the plot directly, rather than the trace. This is shown in the5.
following snapshot. The red-cross point is the place where user inserts the marker. Because the
inserting point is closer to 5 than 4, the new line marker will be put on the 5.

Line marker doesn’t support two different X axis for traces. If you try to do so, you get the6.
following error message:

Line marker doesn’t apply to the Delta or Offset models.7.
Line marker currently only supports max 25 traces or sub traces. This provides a good tradeoff8.
between performance and capacity.

Calculation for line marker is based on the concrete values for trace and the readout can be9.
updated according to traces for both rectangular plot and stacked plot, like following:
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 Max and Min Markers
The Max marker snaps to the maximum data point of a trace, and the Min marker snaps to the
minimum data point of a trace.
You can only move Max and Min markers on a trace if there are multiple (equal) maximum data points
or minimum data points on the same trace.
To move a Max/Min marker to the next or previous Max/Min data point, select the marker and...

Use the arrow keys on you keyboard
Use the arrow buttons on the Marker toolbar
Select Next Data Point or Previous Data Point from the Marker pulldown menu or from the marker
popup menu
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 Snapshot
This is an additional feature of Data Display. If you are running a long simulation and you want to look
at data for a particular point in your design, or you just want to check the progress of your simulation,
you can take a Snapshot of the simulation results to quickly view the data.

 Snapshot in ADS

To launch a snapshot during a simulation from an Advanced Design System schematic window choose
Simulate > Snapshot.

When a snapshot is triggered in ADS, the snapshot display is updated soon after the next available
swept point in done. If a previous request is being processed, the subsequent request is ignored and
following status window is displayed:

Snapshot is being processed, please wait...

The dataset is then updated and the data display window is launched.

Note
If the data display window associated with the particular design or simulation has been previously configured, the window
should display the appropriate graph or output. However, if you have not configured the data display window for your
specific simulation, an empty data display window that includes the dataset attached may appear.

Some additional details for ADS snapshot:

A snapshot request that is sent after a simulation is completed will be ignored.
Snapshot is not available for Momentum simulations.
Snapshot is supported for remote simulations.
Results of source currents (e.g. include, I-Probe) and voltages of named nodes can be displayed
in snapshot; however, measurement data are not always valid. If the measurement variable is
defined on a point base (i.e. does not cross sweep points), and it is defined in the output plan
inside the analysis, it can be displayed in snapshot. Otherwise, the data will be invalid.
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 Eye Diagram FrontPanel
The Eye Diagram FrontPanel enables easy computation of waveform and eye diagram measurements.
Many of the Eye Diagram FrontPanel measurement algorithms are derived from the Agilent
Technologies Digital Communication Analyzer but with simplified implementation. The Eye Diagram
FrontPanel supports the NRZ data type. 

For information on measurement expressions specific to the Eye Diagram FrontPanel, see FrontPanel
Eye Diagram Functions (expmeas) in Measurement Expressions (expmeas).

The Eye Diagram FrontPanel can be accessed from the Data Display window or from the Schematic
window.

To access the Eye Diagram FrontPanel from the Data Display window, choose Tools >
FrontPanel > Eye.
To access the Eye Diagram FrontPanel from the Schematic window, choose DesignGuides >
Signal Integrity Applications > Eye Diagram FrontPanel.

The basic measurements steps are:

Select Dataset.1.
Select Trace.2.
Define Data Rate in frequency units and define a measurement expression if required. See3.
Defining Data Rate.
Select Measurement buttons to display various measurements. See Making Measurements.4.

 

 Defining Data Rate
When you select a trace name, the User Defined Data Rate dialog box appears. The selected trace
name appears in the Enter Trace Expression field. This field can also be used to enter an expression.
For example, the expression in the following dialog box produces the time difference differential NRZ
waveform from a Harmonic Balance simulation.
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For waveform/eye diagram parameters, you need to define the NRZ data rate in the Data Rate field. If
the data rate is unknown, click the Estimate Data Rate button to approximate the rate. For circuit
envelope simulation data, you can define the expression to extract the NRZ baseband envelope using
the frequency index.

  

 Changing Measurement Settings
The Measurement Settings button displays the Plot Settings dialog box. You can define the Start Time,
Stop Time, Data Rate, Eye Boundary and Threshold Settings for waveform and eye diagram
measurements. You can also change the color preference for traces.

To enable trace color grading for rise, fall, and eye diagram traces, select the Color Grade check box
located below the Measurement buttons.

  

 Making Measurements
The Eye Diagram FrontPanel has two different measurement modes:

Oscilloscope Mode

Eye/Mask Mode

  

 Oscilloscope Mode

In Oscilloscope mode, all measurements are performed automatically. Some measurements, such as
peak-to-peak jitter, require user intervention.
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The Waveform button displays the time domain waveform.

The pointer maker on the waveform indicates the segment of the waveform used for parameter
measurement. To change the start and stop values, click the Measurement Settings button then edit
the Plot Settings dialog box.

The Amplitude Histogram button displays the amplitude histogram waveform.

A default sampling rate of 451 samples per wavelength across the time axis and 321 samples across
the amplitude axis is used to construct the amplitude histogram. This provides an idea of the level one
and the zero of the waveform. To smooth out the noisy display of the amplitude histogram, increase
the smoothing factor by adjusting the Smoothing factor slider on the Amplitude Histogram dialog box.
To readout the number of samples and amplitude information, adjust the Marker slider.
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The Rise Time Measurement button displays the overlaid rising edge plot used for rise time
computation.

Rise time is a measure of the transition time of the data on the positive (rising) edge of a waveform.
The edge crosses through the lower, middle, and upper threshold levels. The rising edges, which do
not cross through all three threshold levels, are not displayed and are not included in rise time
computation. Horizontal histograms are created across lower, middle, and high threshold levels of this
display. The mean values at low and high threshold levels are computed for rise time calculation. The
default setting for the threshold levels are the 20% to 80% points on the transition. To change the
default threshold settings, click the Measurement Settings button then edit the Threshold Settings tab
in the Plot Settings dialog box.

Pointer markers are placed at low, middle, and high threshold levels.

The Fall Time Measurement button displays the overlay falling edge plot used for fall time
computation.

Fall time is a measure of the transition time of the data on the negative (falling) edge of a waveform.
The edge crosses through the upper, middle, and lower threshold levels. The falling edges, which do
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not cross through all three threshold levels, are not displayed and are not included in fall time
computation. Horizontal histograms are created across lower, middle, and high threshold levels of this
display. The mean value at low and high threshold levels is computed for fall time calculation. The
default setting for the threshold levels are the 20% to 80% points on the transition. To change the
default threshold settings, click the Measurement Settings button then edit the Threshold Settings tab
in the Plot Settings dialog box.

Jitter is a measure of the time variances of the rising or falling edges of a pulse waveform at the
middle threshold. When a jitter measurement is selected, the instrument's measurement database is
enabled. The waveform data that is sampled is accumulated in the measurement database.

The Rising Edge Jitter Histogram button displays the jitter histogram for the rising edge.

Jitter is a measure of the time variances of the rising or falling edges of a pulse waveform at the
middle threshold. When a jitter measurement is selected, a measurement window is placed
horizontally through the middle threshold. This measurement window is narrow in amplitude. A time
histogram is then generated and the peak-to-peak jitter value is determined. RMS jitter is defined as
one standard deviation from the histogram mean.

In the Rise Histogram dialog box, adjust the sliders on the Window Marker tab to define the
rectangular area for jitter histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the
jitter histogram. If the jitter histogram has a deterministic jitter component, the curve fit can be used
to create a Gaussian curve in the tail region. The mean and standard deviation of this Gaussian curve
is displayed.
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The Falling Edge Jitter Histogram button displays the jitter histogram for the falling edge.

Jitter is a measure of the time variances of the rising or falling edges of a pulse waveform at the
middle threshold. When a jitter measurement is selected, a measurement window is placed
horizontally through the middle threshold. This measurement window is narrow in amplitude. A time
histogram is then generated and the peak-to-peak jitter value is determined. RMS jitter is defined as
one standard deviation from the histogram mean.

In the Fall Histogram dialog box, adjust the sliders on the Window Marker tab to define the rectangular
area for jitter histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the jitter
histogram. If the jitter histogram has a deterministic jitter component, the curve fit can be used to
create a Gaussian curve in the tail region. The mean and standard deviation of this Gaussian curve is
displayed.

The Measurement Summary button displays the measurement summary of the waveform parameters.
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 Eye/Mask Mode

In Eye/Mask mode, the eye diagram is displayed for the user defined data rate and most
measurements are performed automatically.

The Eye Diagram measurement button displays the eye diagram.

The Eye Boundary measurement button displays the detected eye crossing points, the level one and
level zero, the 3 sigma points, and the eye boundary (40% -60%), which indicates the measurement
region between eye crossing points. Use this display to verify and debug eye diagram measurements.

The Eye Rise Time measurement button displays the rising edge trace on the eye diagram.
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The pointer markers indicate the threshold values. The eye diagram level one and level zero
(computed within eye boundary region) are used to compute the threshold levels. Rise time is a
measure of the transition time of the data on the waveform's positive (rising) edge. The edge crosses
through the lower, middle, and upper threshold levels. The rising edges, which do not cross through all
three threshold levels, are not displayed and are not included in rise time computation. Horizontal
histograms are created across lower, middle, and high threshold levels of this display. The mean value
at low and high threshold levels is computed for rise time calculation. The default setting for the
threshold levels are the 20% to 80% points on the transition. To change the default threshold settings,
click the Measurement Settings button then edit the Threshold Settings tab in the Plot Settings dialog
box.

The Eye Fall Time button displays the falling edge trace on the eye diagram.

The pointer markers indicate the threshold values. The eye diagram level one and level zero
(computed within eye boundary region) are used to compute the threshold levels. Fall time is a
measure of the transition time of the data on the negative (falling) edge of a waveform. The edge
crosses through the lower, middle, and upper threshold levels. The falling edges, which do not cross
through all the three threshold levels, are not displayed and are not included in fall time computation.
Horizontal histograms are created across lower, middle, and high threshold levels of this display. The
mean value at low and high threshold levels is computed for rise time calculations. The default setting
for the threshold levels are the 20% to 80% points on the transition. To change the default threshold
settings, click the Measurement Settings button then edit the Threshold Settings tab in the Plot
Settings dialog box.
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The Eye Jitter Histogram button displays the eye diagram jitter histogram.

NRZ Eye Jitter is the measure of the time variances of the rising and falling edges of an eye diagram
as these edges affect the crossing point of the eye. When a jitter measurement is selected, a
measurement window is placed horizontally through the middle threshold. This measurement window
is narrow in amplitude. A time histogram is then generated and the peak-to-peak jitter value is
determined. RMS jitter is defined as one standard deviation from the histogram mean.

In the Rise Histogram dialog box, adjust the sliders on the Window Marker tab to define the
rectangular area for jitter histograms. Adjust the sliders on the Curve Fit tab for Gaussian fitting of the
jitter histogram. If the jitter histogram has a deterministic jitter component, the curve fit can be used
to create a Gaussian curve in the tail region. The mean and standard deviation of this Gaussian curve
is displayed.



Advanced Design System 2011.01 - Data Display

121

The Eye Mask button displays the Eye Mask overlaid on the eye diagram plot.

A mask is a template that defines the regions on the eye diagram plots. Mask testing enables you to
verify that the displayed waveform complies with an industry standard waveform shape. To comply
with the industry standard, the NRZ waveform must remain outside the mask regions. The mask
tracks the waveform as the waveform's parameters are modified. The top, bottom, and center mask is
automatically placed between the eye crossing points.
To modify the mask, adjust the slider bars in the Eyemask dialog box. You can alter the slope, the
center mask length, height and position of top/lower mask. You can also save masks at a global, local,
or workspace level.

The Measurement Summary button displays the measurement summary of the eye diagram
parameters.
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Eye SNR (signal-to-noise-ratio) is calculated as SNR=Amplitude/(sigmalevel1 + sigmalevel0) and shown

in the following figure:

  

 Saving the FrontPanel

The Save As FrontPanel Data Display toolbar icon saves the FrontPanel as a FrontPanel Data Display.
The file is saved with a .dds file extension. To open the saved FrontPanel, choose File > Open from
the Data Display window.

The Save As Regular Data Display toolbar icon saves the FrontPanel as a regular data display and
does not retain the slider information. The file is saved with a .dds file extension.
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 Jitter Analysis FrontPanel
The Jitter Analysis FrontPanel enables easy computation of jitter separation measurements. Many of
the Jitter Analysis FrontPanel measurement algorithms are derived from an Agilent Technologies
Digital Communication Analyzer, but with simplified implementation. 

For information on measurement expressions specific to the Jitter Analysis FrontPanel, refer to the
jitter_separation() function in the Measurement Expressions documentation.

The Jitter Analysis FrontPanel can be accessed from the Data Display window by choosing Tools >
FrontPanel > Jitter Analysis.

Follow these steps to perform jitter analysis:

Open the Measurement Setup dialog.1.
Select the Dataset and a suitable Data Trace.2.
Specify the Clock.3.
Select the Input Data Type.4.
Specify the options related to Input Data Type: Pattern Length or ISI Filter Lead/Lag.5.
Set the optional parameters.6.
Perform the analysis.7.

Caution
Due to memory limitations, large datasets created for performing jitter analysis can cause instabilities in ADS. This
can result in the Data Display window crashing without saving the DDS file. To avoid losing any setup information,
save the DDS file before performing a jitter analysis.

Note
Jitter Analysis generally takes up a lot of memory. It is recommended that you use this feature only on a 64 bit operating
system with more than 2 GB RAM.
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 Measurement Setup Dialog
 
From this dialog, you can specify all of the information required to perform a jitter separation
measurement. The options available on the dialog change slightly depending on the setting for Input
Data Type as shown in the following figures:

To complete a successful analysis, specify the following:

Dataset: This is the dataset file included in your current workspace that contains, at a minimum,
the variable on which the jitter measurement is to be performed. Once this dataset is selected,
the Data Trace Name and Clock Trace Name pull down lists will be populated with the
variables contained in the dataset.
Data Trace Name/Expression: This represents the data on which the jitter measurement is to
be performed. You may either choose a variable name from the list or enter an expression
involving an appropriate variable name. For simplicity, you may select the variable name and
then edit the text to arrive at the desired expression.
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Note
Errors in the expression will not be identified until you try to perform the measurement.

Clock Trace Name/Expression or Bit Period: If the dataset contains a variable that can be
used (either alone or in an expression) as the clock for the measurement, this can be specified.
Alternately, specifying the Bit Period will enable the analysis routines to determine the clock
signal. If the data rate is unknown, click Estimate to approximate the period from the Data
Trace. Once a bit period has been specified, the corresponding data rate is displayed.
Input Data Type: If the input is an arbitrary bit sequence, or is from a PRBS with a register
length greater than 17, choose ARBITRARY. Otherwise, choose PERIODIC.

When Input Data Type is PERIODIC:
Pattern Length: This specifies the number of bits which form one period of the
measurement pattern. It can either be an integer number or an expression that
provides this integer when evaluated.

When Input Data Type is ARBITRARY:
ISI Filter Lead: Sets the number of leading coefficients used in the ISI Filter
(default = -2).
ISI Filter Lag: Sets the number of lagging coefficients used in the ISI Filter
(default = 5).

Note
Clicking on any item on the dialog will change the text in the Help box with some simple information regarding the
expected entry in that item.

 

 Specifying a Time Gate

To perform a jitter separation measurement on a subset of the data trace, specify a time gate which
will limit the data passed to the jitter analysis. Once a data trace has been specified, clicking Set Time
Gate displays a plot of the data along with a dialog containing two sliders used to move start and stop
markers on the plot. The time corresponding to the marker position will display below the sliders. Once
you have selected a suitable window, click OK to return to the Measurement Setup dialog.
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 Specifying Optional Parameters

You can set a variety of optional parameters to improve the performance of the jitter measurement.
These parameters may be specified by clicking Advanced Setup to display the Jitter Measurement
Advanced Setup dialog.

Use this dialog to specify the type of analysis performed by the jitter measurement (Measurement
Mode). By default, the Measurement Mode is set to compute the jitter separation as well as provide
jitter histograms and bit error rate (BER or Bathtub) results.

If a shorter analysis time is desired, change the mode to provide only the jitter separation results. If
the spectrum of the random and period jitter (RJPJ Spectrum) is desired, this can also be specified.

Note
For large datasets, this spectrum computation may require significant computational time.

Note
The plots that will be available after the computation is complete will depend on the Measurement Mode selection.

The Advanced Setup parameters are equivalent to certain command arguments for the
jitter_separation() function. The table below describes each parameter; for additional information, see
the jitter_separation() (expmeas) function in the Measurement Expressions documentation.

Advanced
Setup
Parameter

Equivalent
Command
Argument

Notes

Bit Pattern,
Manually specify

Pattern Manually specify the pattern of bits in one period of the sequence.
Minimum pattern is [0, 1].

Bit Pattern,
Specify using file

Pattern Use a file name to specify the pattern of bits in one period of the sequence.
Minimum pattern is [0, 1].

Bit Pattern Pattern The choices are:
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(10110...)
A pattern entered manually, as an array of 0s and 1s (for example:
[1,0,0,0,0,0,0,0,1,0]).
A path to a pattern file (use the Browse button to find a path). The pattern bits in the
file must be space separated and in a single line.
If no pattern is specififed, the pattern is automatically detected from the signal bits.
For each sequence of data, the pattern is detected and compared with the previous
sequence pattern or the given pattern. If the pattern matches, that particular
sequence of data is used.

Jitter BER Level BERLevel The probability level at which to calculate TJ, RJpp in evaluating bit error rate.
Must be between 1e-40 and 1e-1.
Default setting is 1e-12.

Data
Interpolation

InterType Interpolation to use between points in original data
Choices are None and Linear.
Default setting is None.
For clock-type signals, the DFT is calculated from the uniformly spaced RJ, PJ time
record, where each value in the RJ, PJ time record corresponds to a voltage transition
in the clock-type waveform. For NRZ data-type signals, the RJ, PJ time record is not
comprised of uniformly spaced jitter values. For these signals, the RJ, PJ time record
contains "holes" caused by consecutive logical ones or zeros. The lack of information
about the jitter at times corresponding to these holes makes it impossible to determine
the true RJ, PJ spectrum.

RJ Bandwidth RJBWMode Bandwidth used for computation of random jitter (RJ)
Choices are Narrow (pink) and Wide (white)
Default setting is Narrow (pink)
Jitter analysis uses a spectral technique to separate RJ from PJ. In the RJ, PJ Spectrum
the noise floor or baseline depicts RJ. The narrow spikes above RJ depict PJ (see RJ, PJ
Spectrum graph). This separation works well for wide bandwidth RJ, having a uniform
PSD across the entire jitter spectrum. But in some cases, this is not the norm and the
PJ components appear much broader. In such cases PJ can be mis-represented as RJ
and this affects the TJ (since TJ is a multiplier of RJ). Setting RJ bandwidth mode to
Wide or White treats RJ as flat.

Edges EdgeType Data transition at which jitter is analyzed.
Choose Rising, Falling, or Both.
Default setting is Both.

Data Trace,
Number of
Bits/Sequence

Nbps Number of bits in a sequence or acquisition.
Must be at least the Pattern Length
Nbps is optional and the default is 2 * Minimum # Whole Pattern per sequence * Nbpp
= 2 * 64 * Nbpp. (Nbpp is the number of bits per pattern.) In most cases this default
value would work, but in some cases this value might need to be set manually since
this argument has a direct bearing on the number of serial bits needed for a valid jitter
separation and the RJPJ separation method.

Number of
Sequences

NumSeq Number of sequences in the data.
Must be at least 1.
Can be used to control the amount of data to be used in jitter separation. The default
value is (# TIE Points)/Nbps, and in most cases this would work. But if increased
control is required over the number of bits to be used, this argument can be set to a
different value.

Measurement
Mode, Jitter
Separation
(RJ, DJ, TJ, PJ,
ISI, DDJ)

MeasType Resulting data:

Numeric (single-valued) jitter separation.

Measurement
Mode, Jitter
Separation,
Histograms, BER

MeasType Resulting data:

Numeric (single-valued) jitter separation.
TJ, DDJ, RJPJ Histograms.
DDJ vs. Bit and BER Bathtub.
This is the default setting for Measurement Mode.

Measurement
Mode, Jitter
Separation,
Histograms,
BER, Spectrum

MeasType Resulting data:

Numeric (single-valued) jitter separation.
TJ, DDJ, RJPJ Histograms.
DDJ vs. Bit and BER Bathtub.
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RJPJ Spectrum.
Warning: Computation time may be long.

Help (click on
item for
description)

None This space is used to display information about the advanced settings.
Click on a setting to see the information in the Help window

 

 Performing the Jitter Measurement Computation
Once all of the parameters have been specified, click Start Analysis on the Measurement Setup dialog
to begin the measurement.

Caution
Due to memory limitations, large datasets created for performing jitter analysis can cause instabilities in ADS. This can
result in the Data Display window crashing without saving the DDS file. To avoid losing any setup information, save the
DDS file before performing a jitter analysis.

After responding to some default warnings, the FrontPanel will inform you that it is completing the
computation. Once the computation is complete, the FrontPanel window will appear with the original
data shown and with the jitter separation results displayed as the Measurement Results .

Note
If you do not wish to observe the warning dialogs, select the Do not show this dialog again checkbox.

You may now interact with the results of your computation (assuming that you have selected a jitter
Measurement Mode which generates plots) using the measurements buttons on the left.

Clicking Time displays the time domain waveform of the original data used in the measurement (both
the raw data and the time-gated version if a time gate has been specified).
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Clicking TJ (Total Jitter Composite Histogram) displays histograms of the Total, Random plus Periodic,
and Data Dependent Jitter.

Clicking DDJ (Data Dependent Jitter Composite Histogram ) displays histograms for data dependent
jitter at the rising edge (DDJR), falling edge (DDJF), and both edges (DDJ) if all measurements are
available.

Clicking TJ (Total Jitter Histogram) __ button displays the histogram of the total jitter.
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.
Clicking RJPJ (Random and Periodic Jitter Histogram) displays the jitter histogram for the random plus
periodic jitter.

Clicking DDJ (Data Dependent Jitter Histogram) displays the histogram for the data dependent jitter.

Clicking DDJ vs Bit __ displays the data dependent jitter for each bit index. To limit the range of the
bits shown, use the sliders that appear on the window when this plot is active. You may alternately
specify the bit index by typing the integer value into the corresponding text box.



Advanced Design System 2011.01 - Data Display

131

Clicking BER displays the bit error rate (bathtub) plot as a function of the fraction of the jitter of the
unit interval.

Clicking Spectrum __ displays the frequency spectrum of the random and periodic jitter.



Advanced Design System 2011.01 - Data Display

132

Clicking Quad displays the four of the results together: TJ Composite Histogram, DDJ Composite
Histogram, BER, and RJPJ Spectrum.

  

 Saving the FrontPanel

The Save As FrontPanel Data Display toolbar icon saves the FrontPanel as a FrontPanel Data Display.
The file is saved with a .dds file extension. To open the saved FrontPanel, choose File > Open from
the Data Display window.

The Save As Regular Data Display toolbar icon saves the FrontPanel as a regular data display and does
not retain the slider information. The file is saved with a .dds file extension.

Caution
When you close the FrontPanel, you will lose all of the computed data. This means that when you reopen the file either as
a FrontPanel or a regular data display, you will have to wait for the computation to complete.
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 Load Pull Front Panel
The Load Pull Front Panel is a data display utility that is specifically for plotting data from measured
load pull files (Maury 4.X data). As Maury 4.x Loadpull format is quite flexible, the Loadpull FrontPanel
is limited to Freq and Power Sweeps to produce Loadpull contours. To convert Maury 3.X data format
to Maury 4.X see Converting Maury 3.X format to Maury 4.X format.

Note
The Load Pull Front Panel does not directly operate on Maury or Focus load pull files. You have to “format” them, first. For
details, see Converting Maury 3.X Format to Maury 4.X Format

A sample of Maury 4.X data file format acceptable by Loadpull FrontPanel is shown below:

Maury 4.x Data File
! Power sweep plan data file
! Power sweep plan of freq and pin for LDMOS device.
! Date/time Thu Oct 20 10:47:45 2005
Number of Frequencies = 3
Number of Variables = 2
VAR=<Pin_avail>, Units=<dBm>
VAR=<F0 Load Gamma>, Units=<>
! Freq Points per VAR
0.8000 3 29
0.8500 3 25
0.9000 3 37

Freq = 0.8000 GHz
num_src_harmonics = 1, num_ld_harmonics = 1
valid gamma_src1 gamma_ld1 Freq Pin_avail_dBm Pin_deliv_dBm Refl_coef Refl_dB Pout_dBm
Gt_dB Gp_dB

<chunk of data for frequency 0.85 Ghz>......................
Freq = 0.8500 GHz
num_src_harmonics = 1, num_ld_harmonics = 1
valid gamma_src1 gamma_ld1 Freq Pin_avail_dBm Pin_deliv_dBm Refl_coef Refl_dB Pout_dBm
Gt_dB Gp_dB
<chunk of data for frequency 0.90 Ghz>......................

Freq = 0.9000 GHz
num_src_harmonics = 1, num_ld_harmonics = 1
valid gamma_src1 gamma_ld1 Freq Pin_avail_dBm Pin_deliv_dBm Refl_coef Refl_dB Pout_dBm
Gt_dB Gp_dB
<chunk of data for frequency 0.8 Ghz>......................
In order to successfully read Maury 4.x data file in FrontPanel, the data file must have the keywords
defined above in the bold cases as the parser will looks for these words in order to successfully parse
and read data in ADS Loadpull FrontPanel.

 Starting Loadpull FrontPanel
To start Loadpull FrontPanel from the DDS window choose Tools > FrontPanel > Loadpull.

 Figure: Loadpull FrontPanel Window
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 Reading 4.X Maury Data File with Frequency and Power
Sweep
To read Loadpull measured Maury 4.x data file, click the Select File button from the Loadpull
FrontPanel window and select the Loadpull data file. Once the Loadpull file is read successfully, the
measured parameter/variable is displayed under Parameters.

 Figure: Loadpull file data

 Plotting measured Data Points
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To plot the measured load impedance values on the Smith Chart, click Data Plots button in Loadpull
FrontPanel window. Data Plots is the default selection on starting the Loadpull FrontPanel.

 Figure: Data Plots Button

Under Parameters, select the measured parameter and click Add button to add it to under Traces.

 Figure: Parameters

The measured data points gets plotted on the Smith Chart.

 Figure: Smith Chart

Loadpull Contours: To plot the Loadpull contours click Contour Plots button in Loadpull
FrontPanel window.

 Figure: Contour Plots Button
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For the measured variables, for which you want the Loadpull Contours, select the Parameters and click
Add button to define the Start, Stop, and Step values for the Contour Plots in the pop up window. The
window appears with max and min range of the selected measured variable and you should plot data
within the max/min range. If you try to plot Loadpull Contour below or above the default max/min
range, the Contours will not appear.

 Figure: Define Start, Stop, and Step values

Multiple variables can be added, and same variable can be added multiple times with different data range for Loadpull
Contours.
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To view Loadpull Contours on Rectangular or Polar plot, select the required radio button located on
left side of Loadpull FrontPanel window.

 Figure: View Options

To see the Contours for different power and frequency, activate the slider control by selecting the
measurement variable under Traces. By default Check All checkbox is checked which shows Loadpull
Contours for all frequency and power point in your data. To move sliders, uncheck the Check All
checkbox and use slider control to see Contour for specific frequency and power point.
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 Converting Maury 3.X Format to Maury 4.X Format
Perform the following steps to convert Maury 3.X format files to Maury 4.X format:

From DDS window, choose Tools > FrontPanel > LoadPull to open the Load Pull Front Panel1.
dialog.
Click Select File to open to Maury 3.X Format file.2.
Click the Format Files button to see the Content Browser in the new window.3.



Advanced Design System 2011.01 - Data Display

139

Expand the Loadpull_Files Tree under Content Browser and Select Freq_Group node in order to4.
map Maury 3.X files from ADS workspace directory to Content Browser tree. Once the Freq_Group
node is selected from the Content Browser, folders from $HOME directory gets displayed in the
Select Loadpull_Files field.
Navigate and select loadpull files and Add Loadpull files to the Freq Group using the Button5.
provided at the bottom of "Select Loadpull File" field. This will add Maury 3.X files from ADS
workspace directory to the Freq Group. You can add multiple files representing different power
level under one frequency group.
To add another frequency group, Select Loadpull_Files node of the tree and add another6.
Freq_Group node. Once the Freq Group is added you can add another set of files representing
Loadpull data at a different frequency and varying input power levels.
Select Freq_Group under Content Menu in order to map Maury 3.X files from ADS workspace7.
directory to Content Menu. Once the Freq_Group node is selected from the Content Browser,
folders from $HOME directory gets displayed in the Selected Loadpull_Files field. Navigate, select,
and map Loadpull files.
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Here the data is mapped into three frequency group and every frequency group has three files for
power sweep data ( one file for each power point). The top Freq_Group represents the lowest
frequency and the first file in that group represents the lowest power points and so on.

Enter a new output file name in the text box and click Create File button to save the newly8.
created file.

Once new file is created, you can read this file using Select File button and plot Loadpull contours. For
slider to read Frequency and Pin_avail_dBm value properly, the files have this data defined as one of
the columns under measured variables. If the measured variable Freq, and Gt_dB is not available the
file format utility will automatically insert these variable with 0 values in the new file which will be
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created. In case frequency and power sweep data is not available, the utility can also take single file in
Maury 3.X format and convert it to Maury 4.X format.
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 S-Parameter TDR FrontPanel
The Scattering Parameter Time-Domain Reflectometer FrontPanel (S-Parameter TDR or SP TDR)
enables time-domain reflectometry analysis to be performed when starting with frequency-domain
input S-parameter datasets. Many standard time-domain TDR signal processing techniques, including
such operations as: time-domain gating, frequency-domain windowing, layer peeling, and ideal port
extensions are available in the SP TDR FrontPanel. 

For information on measurement expressions specific to the S-Parameter TDR FrontPanel, see
FrontPanel S-Parameter TDR Functions (expmeas) in Measurement Expressions (expmeas).

The S-Parameter TDR FrontPanel can be accessed from the Data Display window.

To access the S-Parameter TDR FrontPanel from the Data Display window, choose Tools >
FrontPanel > SP TDR.
 

 Overview

The following steps provide a quick overview to start a TDR analysis:

Select a valid S-parameter dataset from the Select Dataset dropdown list. (See Note 1)1.
Select the desired trace. This is often S(1,1) for TDR analysis and S(2,1) for TDT analysis.2.
Choose the desired domain to view: frequency, time, or both (Freq/Time).3.
Enable TDR operations in one of two ways:4.

From default parameters directly in the SP TDR main window, or
From the Settings dialog box.

Set/Enable the optional parameters for TDR operations specific to your dataset.5.
Examine results in the SP TDR main window.6.
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Note
S-parameter datasets should not have any swept variable other than frequency

Caution
Due to memory limitations, large datasets created for performing S-Parameter TDR analysis can cause instabilities or long
delays in ADS when certain operations are enabled. This can result in the Data Display window crashing without saving
the DDS file. To avoid losing any setup information, save the DDS file before performing a TDR analysis.

 TDR FrontPanel Operations
Input S-parameter datasets pass through various operating blocks based on which operations have
been enabled in the Systems dialog or SP TDR main window. Consider each TDR operation or
transform as a specific block that represents the flow of data from input to output; then, a system-
level diagram of the SP TDR FrontPanel would look like the following:
 

Operating blocks that are not enabled specifically from within the SP TDR are "short-circuited" or "off".
Details of each of the system operation blocks and how their parameters are manipulated within the
SP TDR FrontPanel can be found later in the documentation. A synopsis of each of the blocks is
presented here:

 Frequency Domain Operations

Port Mapping - Convert an S-parameter dataset with more than three ports to a 4-port dataset.
Frequency Mode - Select between single-ended or mixed-mode stimuli, including: differential-out
differential-in, common-out common-in, differential-out common-in, common-out differential-in.
Mixed-modes are only available with 4-port datasets.
Low Frequency Extrapolation - Lowpass Time Modes are only available for datasets with data
down to zero frequency. For datasets that are missing these data point, Low Frequency
Extrapolation can be used to enable Lowpass Time Modes.
Smooth - Performs smoothing operations on noisy frequency-domain data.
Port Extension - Add a virtual length of ideal or lossy transmission line to any of the data ports.
Window - Performs a frequency-domain window on the data to minimize ringing in the time-
domain traces.
IFFT - Performs an inverse Fourier transform on the data using the DDS ts() (expmeas) function.

 Time Domain Operations
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Impulse File Writer - Converts input frequency-domain data into causal time-domain impulse
responses.
Peeling - Removes the impedance masking effects of having multiple discontinuities in the device
under test (DUT).
Gate - Time domain removal of impedance sections.
Inverse Peeling - Undo the Peeling algorithm prior to displaying in the frequency domain.
FFT - Performs a Fourier transform on the data using the DDS fs() (expmeas) function.
Time Sweep - Set the maximum and step time values for viewing time domain data.
Time Mode - Choose how the time domain is viewed: Lowpass Impulse, Lowpass Step, or
Bandpass Impulse.

 Enabling TDR FrontPanel Operations

Each of the operations defined above is either always enabled (e.g. FFT/IFFT) or settable within the SP
TDR itself. Each settable operation block can be enabled either directly from the SP TDR FrontPanel
main window or via the Settings dialog box. For example, the Peeling algorithm is enabled by clicking
the associated button on the main window (the light will turn on) which will in turn check the
corresponding box in the Settings dialog box or vice-versa.

 is equivalent to 

Only the eight operations that appear as buttons on the main window are possible to enable/disable in
addition to port mapping which must be enabled from the Settings dialog. All other system blocks are
always "on" though specific parameters pertaining to each can be set within the Settings dialog box.
"Raw" data when viewed in the SP TDR main window only passes through those operation blocks that
are always "on" or which change the bandwidth of the selected dataset.

 S-Parameter TDR FrontPanel Utilities
In addition to operating blocks on the input data, the S-Parameter TDR FrontPanel is equipped with
multiple utilities to make manipulation of datasets easier. These utilities include:

The Data File Utility a read/write tool for Touchstone or Citifile formats.
The Data Editor Tool an S-parameter spreadsheet for direct data manipulation.
Ability to save the SP TDR FrontPanel state as a regular Data Display window for advanced
manipulation.
Each of the utilities are accessed via the SP TDR main window toolbar.

 Data File Utility

The SP TDR FrontPanel Data File Tool is a simple utility to import and export datasets of different
formats.
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Read data file into FrontPanel- the Read option takes a file of Touchstone or Citifile format as
input and converts it into the dataset format useable by ADS Data Displays. A file will be created
with the ".ds" extension which will then be used to populate the SP TDR FrontPanel itself.
Write FrontPanel data into data file- the Write option takes the modified frequency-domain data
from the SP TDR and writes it to a Touchstone, Citifile, or dataset file.

 Data Editor Tool

The S-Parameter TDR FrontPanel Data Editor Tool is a spreadsheet-based utility used for editing
individual ports and data points within a dataset. The Data Editor Tool can be opened from the TDR
FrontPanel main window toolbar.
 

Caution
A large number of ports or data point can cause instability on running the Data Editor Tool for the first time. This can
result in the Data Display window crashing without saving the DDS file. To avoid loss off setup information, save the Data
Display file before opening the Data Editor Tool.

After population of the spreadsheet from the selected dataset, the Data Editor Tool appears.
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Various data manipulation possibilities are available with the Data Editor Tool. Conversions between S,
Z, and Y parameters can be done using the tools along the side of the Data Editor Tool.
 

Additionally, the data format can be converted between Real/Imag, Mag/Phase, and dB/Phase.
Parameters specific to the dataset such as fundamental frequency base and characteristic impedance
can also be set here. Editing the data can be performed directly within the spreadsheet table cells or
via the toolbar buttons along the top of the Data Editor Tool.
 

The functions perform operations such as: adding or removing ports, inserting or deleting rows, and
resampling the data to produce equally spaced frequency samples. In order to clear all data use the
menu function Edit > Clear All.
 

The Open and Save toolbar button allows any dataset, Touchstone, or Citifile to be used within, or
exported from, the Data Editor Tool.

 Viewing TDR FrontPanel as Regular Data Display Window

In order to save the SP TDR workspace as a regular Data Display, and thereby allowing all the
functionality of that type of window, choose Save As Regular Data Display from the SP TDR toolbar.
After saving, close the current SP TDR window, and then open the saved ".dds" file from a regular
Data Display window.
 



Advanced Design System 2011.01 - Data Display

147

 
Viewing the TDR in a Data Display window allows behind-the-scenes manipulation of SP TDR data. For
example, the fixed order of operations for the SP TDR data can be altered by changing the order in
which functions are called in the Data Display. The following is a brief description of each page in the
TDR Data Display:

Help Page - The welcome page for the SP TDR FrontPanel.1.
Freq Domain Page - Contains a single plot for Modified, Raw, and Window frequency-domain2.
traces.
Time Domain Page - Contains a single plot with Modified, Raw, and Gate time-domain traces.3.
Freq/Time Domain Page - Contains both the frequency- and time-domain plots and corresponding4.
traces.
Modified Data Functions Page - This is the central page containing all operations ranging from Port5.
Mapping to Frequency Scaling. Changing the order of these functions will alter TDR results.
Raw Data Functions Page - Operation functions that Raw data passes through.6.
Miscellaneous Functions Page - Used internally by the SP TDR FrontPanel.7.
System Page - Contains nine plots showing traces at the output of each operation box of interest.8.

Caution
Manipulating TDR FrontPanel equations directly from the Data Display window is for advanced users with knowledge of
the Data Display environment and data structures. Altering the order or parameters of the TDR functions can produce
unexpected results.

 TDR FrontPanel Functionality
The following sections will walk through the basic operations and functionality of the SP TDR
FrontPanel. The walkthrough starts with a specific ADS S-parameter simulation and corresponding
dataset. This dataset can be simulated manually or downloaded here . The walkthrough will then give
examples for most of the SP TDR operations using this dataset as input. More detailed explanations
and examples are also available within some of the following sections.

 Example S-Parameter Simulation

The example in the following sections will use a dataset generated from the ADS schematic window.
This simulation setup represents a DUT with multiple ideal transmission line sections of varying
impedance values. The impedance sections will be 40 Ohm, 50 Ohm, 49 Ohm, and a final 50 Ohm
length of ideal line and with 50 Ohm terminations. All lengths of line are lossless. Realistically the

file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
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impedance discontinuities of a DUT would be unknown; however, generating the dataset  in this
manner will be beneficial for examining the various operations of the FrontPanel TDR.
 

After creating the above schematic in ADS, run the simulator in order to create the S-parameter
dataset . For this example the dataset, and hence the schematic, are named "ideal_40_50_49_50" -
the numbers correspond to the impedance sections of the line. Notice that the start frequency of the
simulation component was intentionally set equal to the step frequency (and not 0 Hz). This is done for
a later example of Low Frequency Extrapolation.

After simulating the schematic open the S-Parameter TDR FrontPanel from a Data Display window as
described in S-Parameter TDR FrontPanel. Select the "ideal_40_50_49_50" dataset from the Select
Dataset list in the SP TDR main window. If this is the first dataset selected after opening the
FrontPanel then the SP TDR will automatically precondition the data such that the impedance profile
can be viewed. However, for purposes of this tutorial and to understand the operations involved,
manipulate the SP TDR so that it looks like the following with frequency domain chosen, impulse mode,
and no operations enabled:
 

file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
file:/download/attachments/115607058/ideal_40_50_49_50.ds?version=1&amp;modificationDate=1282038670000
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 Status Panel

Along the bottom of the main window is the status panel which displays various non-settable values
regarding the dataset: Number of Frequency Points, Spatial Resolution, and the Alias-Free Range. In
the TDR, these values are defined as:

 Global Parameters

The distance calculated in the TDR is a function of the relative velocity of propagation. The velocity of
propagation can be defined either in terms of meters/sec, or in terms of the effective relative dielectric
permittivity. The relative dielectric permittivity can be set in the Settings dialog box. This area in
Settings is also used to set the characteristic impedance and time domain x-axis values.
 

 
Dropdown lists at the top of the SP TDR FrontPanel main window manipulate various parts of the
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dataset:

Select Dataset: Choose any valid S-parameter dataset in the current working workspace. For
this example, choose the "ideal_40_50_49_50" dataset.
Select Trace: SP TDR operations can be performed on any of the S-parameters. Typically S(1,1)
is used for TDR analysis and S(2,1) for TDT analysis.
Select Scale: In the frequency domain the scale values are: dB, Magnitude, Phase, Real, and
Imag. In the time domain the scale values become: S-Parameter Coefficient (rho), Impedance, or
Volts. If the Domain viewed is Freq/Time then the Scale is not selectable and the current Scales
will be used.
Select View: Any combination of the original data or the data modified by the SP TDR may be
Viewed.

The remainder of this example will alternate between the main SP TDR window and the Settings dialog
box. Open this dialog by clicking the Settings button.
 

 Port Extension

The Port Extension operation will add a virtual length of ideal, lossless, or lossy transmission line to
any of the input ports of the dataset. This is useful for noncausal data or for simple masking
extraction. For the "ideal_40_50_49_50", notice that a reflection occurs at time t=0 which results in
noncausal effects at time t=10 ns. To overcome this problem first enable Port Extensions in the
Settings dialog box.
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Now increase the length of the extension to 15mm which is a fractional wavelength. The result is a
well behaved time domain trace without any reflections at unwanted times.
 

 Time Sweep

The Time Sweep area within the Settings dialog box is a good method of altering the view of the time
domain trace and is different than simply zooming in on the desired time range. For example, use the
main window to first change the Domain to Time and then use the toolbar buttons to zoom into the
range from 0ns to 1ns.
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Notice that the resolution is poor. This occurs since zooming in the plot does not change the number of
time domain samples; however, setting the Time Sweep alters the manner in which the IFFT is
performed. Enable Time Sweep with sweep settings ranging from 0ns to 1ns with 401 temporal data
points.

Though the time extent of the plot does not change, the resolution of the trace is much better now.
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Unfortunately, there is significant ringing in the trace which will be taken care of by the Window
operator.

 Window

Windowing in the frequency domain is a popular method of lessening the high frequency content in the
time domain which lowers overall ringing of the waveform. Windowing can be enabled with default
values by pressing the Window button in the main window or by clicking Enable in the corresponding
area of Settings dialog box.
 

 
In addition to enabling the Window you can also select Display Window to see a scaled, overlaid
trace of the Window response. Note that since there is no zero frequency point in the dataset, the
Time Mode of the trace is fixed at Bandpass Impulse and the Window function is also bandpass.
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Change the SP TDR Domain in the main window to Freq/Time in order to see the Windowed frequency
domain data and the time domain trace with less ringing. In order to enable lowpass Time Modes and
examine the lowpass impulse and step responses of the data, the frequency data needs to start at 0
Hz. Low Frequency Extrapolation is used to find these points and enable lowpass Time Modes.

 Low Frequency Extrapolation

Low Frequency Extrapolation is a simple method to extrapolate any number of data points from the
lowest frequency value in the dataset down to 0 Hz.
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A quick method of setting up Low Frequency Extrapolation is to press Make Lowpass Waveform in
the Time Modes section of the Settings dialog box.
 

Notice that after pressing Make Lowpass Waveform, both Lowpass Time Modes as well as Low
Frequency Extrapolation are enabled. Additionally, the Time Mode is automatically switched to the
lowpass step mode. The result in the main window is a lowpass Window in the frequency domain and
an impedance step response in the time domain.

Caution
To accurately predict low frequency values, the time domain waveform must be causal. Noncausal data without a zero
frequency point may result in inaccurate results.

 

An interesting phenomenon occurs with closer examination of the time domain step response (you
may want to set Domain to time for a better view). The impedance plot follows the expected values of
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impedance sections from the simulated transmission line with a couple of exceptions. The first length
of 50 Ohm line (after the extended port) is not quite exact nor is the following length of 49 Ohm line.
This behavior is explained in the next section and can be counteracted by the Peeling algorithm.

 Peeling

When multiple discontinuities exist in a DUT then masking will occur at the output port. This means
that energy from close-in discontinuities are reflected thus masking the true reflection coefficient from
further-out discontinuities. For example, consider the forward and reverse traveling waves at the
boundary of the kth discontinuity
 

where reflection coefficient is defined by the reflected and incident voltages impinging on the sections

Using a recursion relation on the total of all reflected and incident waves, the original impedance value
can be calculated. This is what the Peeling algorithm does.
Enable Peeling either by pressing the button on the TDR main window or selecting the checkbox in the
Settings Dialog box.

The corrected impedance values are now shown in the time domain step response. Note that the 50
and 49 Ohm lines are now more precisely represented in the impedance profile.
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Note
Since Peeling algorithm can produce unrealistic frequency domain response only time domain trace will change when
Peeling is enabled.

 Gate

The Gate functions removes unwanted discontinuities as seen in the time domain allowing a view of
the results in the frequency domain. Depending on the selected Time Mode, the Gate function behaves
differently on time domain data.

As an example of the Gate function:

First press Autoset Min/Max/Step to get a good discretizaion of Gate values.1.
Next select Display Gate so the Gate window shows up in the main display.2.

There are three methods of altering Gate values:
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Input Start/Center Length/Width values directly into the Settings dialog area.1.
Use the sliders to manipulate the Gate.2.
Directly drag-and-drop the Gate from within the main TDR window.3.

For this example, isolate the 49 Ohm section of line by setting the Start time to .27ns and the length
to .15ns. Also, switch the Gate Type to Notch in order to remove everything within the Gate window.
 

The 49 Ohm line is removed and replaced by an ideal (no reflections) connection between adjacent
sections. The frequency response changes to match the new time step response.

 Other Operations
In addition to standard SP TDR Operations that were covered in the walkthrough, the SP TDR
FrontPanel contains features for data preconditioning and mixed-mode S-parameter analysis.

 Smooth

Consider a lossless S-parameter simulation that has been corrupted by noise in the frequency domain.
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This dataset was created in ADS but could represent S-parameter extraction for an actual network
analyzer. Smoothing operations on the input data can be enabled in the SP TDR for either Moving
Average or Alpha-Beta filters.

   

With the appropriate settings, these functions can remove much of the noise seen in the input dataset.
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 Impulse File Writer

The ADS Impulse File Writer(IFW) component provides for a time-domain convolution simulation of S-
parameter data. In the SP TDR FrontPanel, the IFW simulation opens an ADS schematic window,

converts the currently selected S-parameters into time domain impulse responses, which accurately
represent the original spectrum, which are then read back into the SP TDR without overwriting the
current dataset itself. The causality problem associated with band-limited spectrum is circumvented
using proprietary technology and the computed impulses are guaranteed to be causal. To run the IFW
simulation simply press the IFW button on the main window or select "Run IFW Simulation" from the
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settings dialog

The IFW simulation will automatically open a new simulation design with the appropriate components.
Once the simulation has terminated, the time-domain impulse data for the selected dataset will be
read into the TDR as long as the IFW operation is "on".

Caution
The SP TDR FrontPanel IFW simulation only allows input datasets with up to four ports. Larger datasets would need to be
simulated manually with the IFW component prior to manipulation within the SP TDR FrontPanel.

 Port Mapping

Port Mapping accepts as input a dataset with N>3 ports and converts it to 4-ports in the desired order.
To open Port Mapping dialog box, click on Map Ports... in the Frequency Mode area of the Settings
dialog box.
 

For datasets with less than four ports Port Mapping is not available. After selecting Map Ports... the
Port Mapping dialog box will appear.
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Using the dropdown lists allows any port from the input dataset to be mapped to one of four ports for
differential S-parameter analysis or for nominal single-ended use.

 Mixed-Mode S-Parameters

 

The SP TDR is capable of converting from a 4-port single-ended dataset into 2-port mixed-mode
datasets. Mixed-mode simulations are often used for high-speed circuits such as PCB or amplifiers to
examine the DUT behavior with differential or common mode stimuli. For example, consider a pair of
coupled transmission lines with a common grounding plane:
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This device can be excited in various manners depending on the desired even or odd mode. For clarity
we write the above circuit, or any such DUT, as a 4-port black box.
 

with a common terminal. Each of the mixed-mode stimuli demonstrate different aspects of the DUT
 

Single-ended S-parameter simulation with differential or odd-mode stimuli.
Used for analyzing differential behavior of the DUT.
Is most often the "desired" signal.
 

Demonstrates susceptibility to external interferes.
Sdc is ideally zero.
 

Demonstrates EM noise "leakage" from the DUT to other interconnects.
Coupled imbalance is detimental to overall performance.
Scd is ideally zero.
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Single-ended S-parameter simulation with common- or even-mode stimuli.
Is most often the "undesired" signal.

One of the key benefits is that only a single 4-port simulation performed on the DUT is necessary.
After simulating, linear conversions can be performed on the S-parameter matrices in order to view
the desired mixed-mode traces.
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 Exported List Data (CSV Format)
As explained in Exporting a Data Display List to a CSV file (data), data from list plots can be exported
in CSV format. This section provides more detailed information about CSV data export.

 About the Format
The comma separated values format (CSV) is a popular solution to the problem of exchanging and
converting data between various applications and spreadsheet programs. The Data Display export
feature adheres to the CSV standard as it is formally described at: http://tools.ietf.org/html/rfc4180 .

 CSV Data Export Process
The user can export data from a list by either of the following methods:

Using the context-sensitive popup menu for a List plot, and selecting Export/CSV File.
Using the pulldown menu pick File > Export > List to CSV File.

After the user selects one of these menu picks, the standard file browser is then displayed, and the
user is allowed to enter a file name for the export file. The CSV extension is automatically added to the
file. When the user selects the OK button, the data is exported. The data is exported using the same
numeric format that is displayed in the list plot. For more information about list formatting, see Editing
Lists (data).

Data can only be exported from list plots. Other plot types will not support export of CSV data.

 Multiple list plots

Multiple objects may be pre-selected before executing the export menu pick. In this case, any object
that is not a List plot will be ignored. Post-selection is not supported. If no list plots are selected, the
export menu pick is inactive.

If multiple listings are exported, all the data will be placed in the CSV file side by side. However, the
independent data will not be shared between listings even if the data is equivalent. For example, if two
listings have data that depends on "freq", the data for "freq" will be exported twice into the CSV file
(once for the first listing and once for the second listing).

 Independent Data

Independent data is exported only if the Display Independent Data checkbox (in the Plot Options
for the list plot) is checked. However, the box is checked by default when a list plot is created.

The independent data is always exported before the dependent data. If the last independent data is
the same as the current independent data, then only the dependent data will be exported. That is, the
data is exported as it is displayed in the list plot. If there are two traces with the same independent
data, then that data is displayed only once in the listing. However, if the independent data is different,
then each trace will have its own column for independent data; the same is true of the exported CSV
data.

 Matrix Data

Matrix data has each matrix element exported in a separate column. For example, if the List plot has
S-Parameter data and the user has listed S, instead of S being exported, each column is listed
separately in the export file. If the S-Parameter data is defined as a 2x2 matrix, then the user will see
in the export file S(1,1), S(1,2), S(2,1) and S(2,2) as individual columns.

http://tools.ietf.org/html/rfc4180
http://tools.ietf.org/html/rfc4180
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Note
An application such as Excel may or may not accept complex numbers stated in a given format. Users need to display
complex numbers in Data Display lists in whatever format is acceptable to the application to which the data will be
transferred, so that the exported CSV data can be imported successfully by that application. For more information about
complex numbers in lists, see Setting List Preferences (data).

 Swept Data

Swept data will generate a column for each sweep that the data being exported depends upon. The
columns will be created in the same order as the dependency for the data.

 Simple Data Export Example
In this example the exported data is very simple (it isn't swept, and isn't matrix data):

In this case the data being exported has a dependency on the data called "freq"; it has 10 data points,
is scalar (not a matrix) and is real data:

In the listing below, you can see the output in CSV format. Notice that the first line includes the
header information obtained from the what() command for the trace and other sources. Since the data
is coming from a list plot, the format of the exported data will match the format of the data in the list:

"freq

References : ['data']

Dependency : []

Num Points : [10]

Matrix Size : scalar

Type : Real","data

References : []

Dependency : [freq]

Num Points : [10]

Matrix Size : scalar

Type : Real"

1.000 GHz,-0.342

1.100 GHz,-0.278
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1.200 GHz,-0.128

1.300 GHz,-0.009

1.400 GHz,-0.037

1.500 GHz,-0.182

1.600 GHz,-0.313

1.700 GHz,-0.335

1.800 GHz,-0.233

1.900 GHz,-0.078

 Matrix Data Export Example
In this example the data being exported is matrix data. In this case we are exporting a 2x2 matrix.
The data being exported is complex data:

The "what(data)" information for the data is:

The data is exported as:

"freq

References : ['data(1,1)','data(1,2)','data(2,1)','data(2,2)']

Dependency : []

Num Points : [10]

Matrix Size : scalar

Type : Real","data(1,1)

References : []

Dependency : [freq]

Num Points : [10]

Matrix Size : (2,2)

Type : Complex

Complex Format : dB/Rad","data(1,2)

References : []

Dependency : [freq]

Num Points : [10]

Matrix Size : (2,2)

Type : Complex

Complex Format : dB/Rad","data(2,1)

References : []

Dependency : [freq]

Num Points : [10]

Matrix Size : (2,2)

Type : Complex

Complex Format : dB/Rad","data(2,2)
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References : []

Dependency : [freq]

Num Points : [10]

Matrix Size : (2,2)

Type : Complex

Complex Format : dB/Rad"

1.000 GHz,-9.312 / -3.141,-0.541 / 1.571,-0.541 / 1.571,-9.312 / -3.142

1.100 GHz,-10.209 / 2.695,-0.435 / 1.124,-0.435 / 1.124,-10.209 / 2.695

1.200 GHz,-13.581 / 2.229,-0.195 / 0.658,-0.195 / 0.658,-13.581 / 2.229

1.300 GHz,-24.899 / 1.738,-0.014 / 0.167,-0.014 / 0.167,-24.899 / 1.738

1.400 GHz,-19.026 / -1.904,-0.055 / -0.333,-0.055 / -0.333,-19.026 / -1.904

1.500 GHz,-12.060 / -2.387,-0.279 / -0.817,-0.279 / -0.817,-12.060 / -2.387

1.600 GHz,-9.699 / -2.845,-0.492 / -1.274,-0.492 / -1.274,-9.699 / -2.845

1.700 GHz,-9.407 / 2.994,-0.529 / -1.719,-0.529 / -1.719,-9.407 / 2.994

1.800 GHz,-10.974 / 2.543,-0.362 / -2.170,-0.362 / -2.170,-10.974 / 2.543

1.900 GHz,-15.747 / 2.068,-0.117 / -2.645,-0.117 / -2.645,-15.747 / 2.068

 Swept Data Export Example
In this example a simple data sweep is handled.

The "what(data)" information for the data is:

The data is exported as:

"Zo1

References : ['data']

Dependency : []

Num Points : [2]

Matrix Size : scalar

Type : Real","freq

References : ['data']

Dependency : []

Num Points : [10]

Matrix Size : scalar

Type : Real","data

References : []

Dependency : [Zo1,freq]

Num Points : [2,10]

Matrix Size : scalar

Type : Real"
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35.000,1.000 GHz,-0.342

35.000,1.100 GHz,-0.278

35.000,1.200 GHz,-0.128

35.000,1.300 GHz,-0.009

35.000,1.400 GHz,-0.037

35.000,1.500 GHz,-0.182

35.000,1.600 GHz,-0.313

35.000,1.700 GHz,-0.335

35.000,1.800 GHz,-0.233

35.000,1.900 GHz,-0.078

85.000,1.000 GHz,0.486

85.000,1.100 GHz,0.528

85.000,1.200 GHz,0.594

85.000,1.300 GHz,0.601

85.000,1.400 GHz,0.514

85.000,1.500 GHz,0.332

85.000,1.600 GHz,0.091

85.000,1.700 GHz,-0.107

85.000,1.800 GHz,-0.145

85.000,1.900 GHz,-0.056

 Swept Matrix Data Export Example
The final example will show a mix of swept matrix data. The data display listing is:

The swept matrix data "what()" output.is:
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The swept matrix data is exported as:

"Zo1

References : ['data(1)','data(2)']

Dependency : []

Num Points : [2]

Matrix Size : scalar

Type : Real","freq

References : ['data(1)','data(2)']

Dependency : []

Num Points : [10]

Matrix Size : scalar

Type : Real","data(1)

References : []

Dependency : [Zo1,freq]

Num Points : [2,10]

Matrix Size : scalar

Type : Real","data(2)

References : []

Dependency : [Zo1,freq]

Num Points : [2,10]

Matrix Size : scalar

Type : Real"

35.000,1.000 GHz,-0.342,-1.622e-16

35.000,1.100 GHz,-0.278,0.411

35.000,1.200 GHz,-0.128,0.774

35.000,1.300 GHz,-0.009,0.984

35.000,1.400 GHz,-0.037,0.939

35.000,1.500 GHz,-0.182,0.663

35.000,1.600 GHz,-0.313,0.276

35.000,1.700 GHz,-0.335,-0.139

35.000,1.800 GHz,-0.233,-0.541

35.000,1.900 GHz,-0.078,-0.867

85.000,1.000 GHz,0.486,01.796e-16

85.000,1.100 GHz,0.528,0.420

85.000,1.200 GHz,0.594,0.668

85.000,1.300 GHz,0.601,0.755

85.000,1.400 GHz,0.514,0.741

85.000,1.500 GHz,0.332,0.638

85.000,1.600 GHz,0.091,0.403

85.000,1.700 GHz,-0.107,-0.002

85.000,1.800 GHz,-0.145,-0.493

85.000,1.900 GHz,-0.056,-0.868

Here is the data imported into Microsoft Excel:
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Note
By default, the header line diplays the name only; clicking on the cell causes the entire header entry to be displayed.
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 Running the Data Display as a Stand-Alone
Program
This section explains how to use a command line to run the Data Display as an independent
application.

Note
Command-line functions depend upon the proper setup of environment variables (such as HPEESOF_DIR). See Windows
Installation (instalpc) or UNIX and Linux Installation (install), as appropriate, for more information about these variables.

 The dds Command
To invoke Data Display as a stand-alone program, open a shell window (or command prompt window,
in the Windows PC environment) and use the dds command:

dds [-dataset ] [-cmd ] [-32bit] [-64bit] []

The options and arguments for this command do not need to be placed in the order shown above. Any
of them can be omitted, and some of them can be repeated within the command line.

Each time the dds command is issued, a new Data Display process is started. A process started in this
way will not communicate with or be aware of other Data Display processes which may be running,
regardless of how they were launched (by command or from within ADS or GoldenGate sessions).

The Data Display process that is started by the dds command will monitor the data directory for
changes in datasets, and update any plots utilizing data that has changed.

The options and arguments for the dds command are listed in the table below.

Option/Argument Description

-dataset

<datasetFile>

The parameter passed in here is the path and name of a dataset file (<path>/<filename>.ds); make
this the default dataset, to be used for all subsequent Data Display files and windows opened (until
another -dataset option changes it). This option can be repeated within the command line. Relative path
names to the dataset file are acceptable. See Using the -dataset Option below for details.

-cmd

<commandFile>

The parameter passed in here is the name of a command file; execute the commands contained in this
file. See Using the -cmd Option below for details.

-32bit On a 64-bit system, start the Data Display in 32-bit mode. In Microsoft Windows, 32-bit mode is the
default setting; in UNIX or Linux, the appropriate mode is set automatically.

-64bit On a 64bit system, start the Data Display in 64bit mode. In Microsoft Windows, 32-bit mode is the
default setting; in UNIX or Linux, the appropriate mode is set automatically.

<dataDisplayFile> The path and name of an existing Data Display file (<path>/<filename>.dds). Use the Data Display
window (as defined in this file) to show the content of the default dataset (as specified by the -dataset
option). This argument can be repeated within the command line. If the argument is omitted, a new
and unnamed Data Display window is opened. If the Data Display file exists in the directory where you
execute the dds command then no paths specification is required. Relative path names are acceptable.
See Using the <dataDisplayFile> Argument for details.

 File Paths in the dds Command
Where file names are given in the dds command (or in a command file referenced by the dds
command), the file is assumed to be located in the current working directory; if it is not, use a file
path relative to the working directory.
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Note
If you use the dds command in the Windows PC environment, be aware that the command cannot be called from any
location for which the file path includes spaces (for example, "C:\Documents and Settings").

 

 Using the -dataset Option
The -dataset command line option specifies that the next parameter on the command line names the
file that is to be used as the default dataset. This default dataset will replace the default dataset
specified in the Data Display file, and will be used by any new Data Display windows launched:

dds -dataset data/set1.ds disp1.dds

This option can be repeated as many times as necessary within the command line, to use a different
dataset for each of several Data Display files:

dds -dataset data/set1.ds disp1.dds -dataset data/set2.ds disp2.dds -dataset

../other_wrk/data/set3.ds disp3.dds

Note
The data display file and data directory in which the dataset file resides are expected to share the same parent directory:
parentDirectory/dataDisplayFile

parentDirectory/data/datasetFile

If this condition is met, the dataset is added to the data display file as the normal default dataset. However, if the parent
directories are not the same, or if the data directory is called something other than data, an alias is created for the
dataset, and that alias is used to specify the default dataset for the data display file.

If the specified dataset is not found, this option will be silently ignored.

If this option is omitted from the command, or if it is ignored because the specified dataset is not
found, the default dataset of the data display file is used.

 

 Using the -cmd Option
The -cmd command line option specifies that the next parameter on the command line names a file
containing commands which are to be processed by the Data Display before control is passed to the
user.

dds -cmd file1.cmd

If the command file is located in the current working directory, the filename alone is sufficient; if it is
located elsewhere, enter a path relative to the working directory, or an absolute path.

Note
It is not necessary to give the command file the .cmd file extension (or any other file extension), but doing so is an easy
way to make command files recognizable.

This option can be repeated as many times as necessary within the command line, to process
commands from multiple files:

dds -cmd file1.cmd -cmd file2.cmd -cmd file3.cmd
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The command file can contain any combination of the commands listed in the table below. Each
command is placed on its own line in the command file. The commands can be repeated as many
times as necessary, and placed in any sequence. (However, any command which is placed after an
EXIT command will not be executed.)

Command Purpose

CMD NEW_WIN Open a new Data Display window.

CMD CHDIR <dir> Change the current working directory to the directory specified. The directory
change only applies to commands following the CHDIR command.  Multiple CHDIR
commands can be included in a single command file. If no CHDIR command is
included in the command file then the directory where you started the dds
command will be used as the current working directory.

CMD OPEN_FILE <dataDisplayFile> Open the specified Data Display file. Full, relative and no path can be used with the
Data Display file name. (The file must exist already; if it does not, this command is
ignored.)

CMD CLOSE_FILE <dataDisplayFile> Close the specified Data Display file. Full, relative and no path can be used with the
Data Display file name. (The user will be prompted to save any changes.)

CMD CREATE_OR_OPEN_FILE

<dataDisplayFile>;<templateFile>

Open the specified Data Display file (creating it if it does not already exist), and
insert the specified template file if the Data Display file is empty. If the Data Display
file is not empty, the <templateFile> parameter is ignored. The <templateFile>
argument can be omitted , in which case the Data Display file is left as is. Full,
relative and no path can be used with the Data Display and Template file names.
The semi-colon (";") is required between the Data Display file name and the
Template file name.

CMD MOST_LIKELY_DATASET

<datasetFile>

Use the specified dataset file as the default dataset for new Data Display windows.
This command only accepts the dataset file name without any path specification.
The dataset is expected to reside in the data directory that exists in the current
working directory. (This command is ignored if the named file does not exist.)

CMD SET_DEFAULT_DATASET

<datasetFile>

Use the specified dataset file as the default dataset for the current Data Display
window only. This command only accepts the dataset file name without any path
specification. The dataset is expected to reside in the data directory that exists in
the current working directory of the Data Display file. (This command is ignored if
the named file does not exist.)

EXIT Exit the current Data Display session without saving. (This command is not
preceded by CMD.)

For example, if the command file called invok1.cmd contains these commands:

CMD OPEN_FILE win1.dds

CMD SET_DEFAULT_DATASET dat1.ds

The effect of entering the command line dds -cmd invok1.cmd would be to open a Data Display
window which shows the Data Display file win1.dds and uses dat1.ds (located in the data subdirectory
of the current working directory) as the default dataset for that display.

 

 Using the <dataDisplayFile> Argument
This argument is used to specify the name of an existing Data Display file (<filename>.dds), which
determines the configuration of the new Data Display window which is opened by the dds command.

The file named in this argument must exist already; if the name specified does not match an existing
file, this argument is ignored and a new, unnamed Data Display window is opened by the command.

This argument can be omitted, in which case a new, unnamed Data Display window is opened by the
command.
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This argument can be repeated as many times as necessary within the command line to open multiple
Data Display windows:

dds -dataset data/set1.ds disp1.dds disp2.dds disp3.dds

In the example above, three Data Displays are opened, using three different Data Display files, but the
same dataset is used for all three because the command specifies the dataset only once. It will also
become the default dataset used by new Data Display files that are created.
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